What versions of the SDK are used with versions of the NS and DS?