"Unable to connect to the server specified" error during the replication of Endpoint Protection Manager
search cancel

"Unable to connect to the server specified" error during the replication of Endpoint Protection Manager

book

Article ID: 151651

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

In a Symantec Endpoint Protection Manager (SEPM) replication setup, after a Replication Partner is added, the error "Unable to connect to the server specified" occurs.
More errors may also appear.

Symptoms
The following errors occur:

  • Error "Unable to connect to the server specified" during the first replication on the destination Manager, while trying to add the replication partner via the Management Server Configuration Wizard. After this error the destination Manager installation is damaged due to the database replication failure.
  • Error "Retrieval of local changed data for replication requested by remote server x.x.x.x failed during retrieving data! [reason: Failed to retrieve Metadata - Java heap space]" in Admin > Server > Notification Area of the source Manager.
  • Error "java.lang.OutOfMemoryError: Java heap space" in the scm-server-0.log of the source Manager.
  • Error in the Catalina.out log:
    NFO: Initializing Coyote HTTP/1.1 on http-9090
    May 12, 2009 12:19:58 PM org.apache.coyote.http11.Http11BaseProtocol init
    SEVERE: Error initializing endpoint
    java.io.IOException: Keystore was tampered with, or password was incorrect
    at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:768)
    at java.security.KeyStore.load(KeyStore.java:1150)
    at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(JSSESocketFactory.java:287)

 

Cause

The SEPM is a Java-based application, much of its performance is related to the size of the "Java Heap".
Modifying the settings that control the size of the Java Heap will improve the performance of a wide variety of the functions performed by the Symantec Endpoint Protection Manager.

Resolution

To adjust the SEPM heap size:

    1. Click Start> Run.
    2. In the Run dialog box, type regedit
    3. Press Enter.
    4. Locate the following registry key:
      HKLM\SYSTEM\CurrentControlSet\Services\semsrv\Parameters\
    5. Locate the following keys:
      JVM Option Number 0
      JVM Option Number 1
    6. Adjust the key values upward, and for optimal performance, match the key values.
      For example, to create a 1 GB static heap, set: "JVM Option Number 0" to "-Xms512m", and set "JVM Option Number 1" to "-Xmx1024m".
    7. Close Regedit.
    8. Click Start > Settings > Control Panel > Administrative Tools
    9. In the Services dialog box, right-click Symantec Endpoint Protection Manager, and then click Restart.

Reference : Performance tuning for the manager

Additional Information

The Heap Size for SEPM is specified with two values, stored in the registry.

    • JVM Option 0 specifies the minimum size of the Java Heap
    • JVM Option 1 specifies the maximum size of the Java Heap.

The default value for JVM Option 1 is 256 MB, while the default value for JVM Option 0 was reduced from 256 MB to 64 MB in SEP 11 MR2 to reduce the memory footprint of the application in smaller environments - the application will automatically increase the size of the Java Heap as required until it encounters the configured maximum size.

These values can be increased to better suit the available resources on the computer; performance can be optimized by following the guidelines below:

    1. The Java Heap starting value () must not be larger that the Java Heap maximum value ().
    2. If the working size of the Java Heap exceeds the available physical RAM, the computer will begin paging the Java Heap. This will dramatically increase Disk I/O and reduce the overall performance.

Note: Always allow for at least 256 MB to be allocated to the Operating System.
For Example: On a computer with 1 GB of RAM, the maximum value for the Java Heap should not exceed 768 MB.