Error: The console was not able to connect to the site you selected.
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Error: The console was not able to connect to the site you selected.

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Article ID: 151978

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Updated On:

Products

Ghost Solution Suite Deployment Solution

Issue/Introduction

When attempting to open the Altiris Deployment Server console the following error occurs:

"The console was not able to connect to the site you selected.  Enter the user name and password to connect to the site or select cancel to select another site."

Cause

When the Altiris Deployment Server console first opens it verifies the ODBC Altiris eXpress System DSN.  From there it obtains the following information:  SQL server, express database name and client configuration properties.

This is problem generally caused by:
  1. The ODBC settings not being configured properly.  (see solution A)
  2. The user does not have administrative rights on either the local machine or  to the Deployment Server machine (See solution B)
  3. The user that is logged in does not have DBO rights to the eXpress database. (See solution C)
  4. Problems with network connectivity to the SQL server. (See solution D)
  5. The SQL server is not functioning correctly. (See solution E)

Resolution

Solution: Review the following solutions and try them in the order most applicable to your environment.

Solution A:

    1. Go to Start > Settings > Control Panel > Admin Tools > Data Sources ODBC > System DSN tab. 
    2. Highlight the Altiris eXpress Database source. Click on 'Configure'
      1. On the first configuration page verify the name of the SQL server in the Server drop down menu. This should   be  the name of the machine that has SQL installed with the eXpress database.
      2. Click Next and verify that the authentication method is correct.  Windows NT is the most common authentication method used.
      3. Click next again.  Verify that the name of the default database is set to 'express'.  (DS 6.5 allows the database name to be changed during install.  Use the approriate name) Ensure that the check boxes for "Use ANSI quoted identifiers" and "Use ANSI nulls, paddings, and warnings" are checked. 
      4. Click next again and then click finish.  Select "Test Data Source". If the test fails because of an authentication problem, you do not have DBO rights to the eXpress database (see Cause 3).

If you are still unable to connect resulting in the same error message, it could be that the server is unable to resolve using named pipes or TCP/IP.  Try switching from one to the other in the client configuration. These options can be found in the "Client Configuration" button on the 2nd page of the wizard. If this does not help the first time then try one of the other suggested solutions, and try toggling between TCP/IP and Named Pipes again.

Solution B:

In the .\deployment server\techsup directory is a utility called 'DSDBsecurity'.  Double click on this executable, authenticate and select 'Set Role Permissions' This utility gives all users who are member of the Public group within SQL rights to open up and use the console. 

Solution C:

Make sure the user is a member of the public group on the SQL server.  Run DSDBsecurity.

Solution D:

Check any firewalls between the machine running the Altiris eXpress Server service and the machine opening the console. Firewalls and proxy servers can be the cause of some Remote Consoles not opening while other Remote Consoles and the Main DS console CAN be opened,  If the Remote Console is going through a firewall then go back into the "Client Configuration" settings in the Altiris eXpress Database ODBC System DSN (as described in Solution A).  Uncheck the "Dynamically Determine Port" and specify a specific port for the console to communicate on.

Solution E:

There are several reasons that SQL could fail. Whenever SQL does fail it is a good idea to first check the windows event viewer logs and the SQL error logs. Often times SQL will fail because of a transaction log growing too large, this is largely due to the high number of transactions Deployment Server has with the database. To prevent this by set the recovery model on the eXpress database to simple or add a maintenance plan to backup the eXpress database nightly. For more information search for "database recommendations" in the Altiris Support Knowledge base and review the SQL user guide.