Error "Error occurred attempting to add Linked Server" occurs when configuring IT Analytics
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Error "Error occurred attempting to add Linked Server" occurs when configuring IT Analytics

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Article ID: 152982

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Updated On:

Products

IT Analytics ServiceDesk

Issue/Introduction

When clicking on the Create or Save buttons in IT Analytics Connections for Symantec Endpoint Protection or Symantec ServiceDesk, the error (or a similar one regarding "linked server") "Error occurred attempting to add Linked Server" occurs.

Error occurred attempting to add Linked Server. View the Log for more details.

In the log, errors such as the following appear:

Linked server ITANALYTICS_SD_SYMANTEC_CMDB_<hostname_or_IP>_PROCESSMANAGER already exists.

Cause

SQL permissions have not been added to create or connect to a linked server, permissions have not been granted on the SQL Server or the linked server object is corrupt.

Resolution

Several pre-requisites may need to be in place before the Endpoint Protection and ServiceDesk Pack configurations can be created or saved. Some or all of these may be necessary depending on the SQL version used.

Enable Permissions to Create a Linked Server on the Symantec Management Platform's SQL Server

  1. On the Symantec Management Platform 7.x (SMP) Microsoft SQL Server, click on the Windows Start button > All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio.
  2. Log into the SQL Server Database Engine.
  3. Click to expand Security > Logins.
  4. Double click on the account that you are logged in as, which may be the Altiris Service Account /App ID
  5. Click on Server Roles.
  6. Click to enable public and sysadmin.
  7. Click on the OK button.
  8. Click to expand Server Objects > Linked Servers.
  9. If a linked server object for IT Analytics exists, right click on it and choose Delete. This may be named similarly to "ITANALYTICS_SD_SYMANTEC" with other text following "Symantec". In any case, if a linked server for IT Analytics exists, it will start with "ITANALYTICS".
  10. Close SQL Server Management Studio. 
     

Configure IT Analytics for Endpoint Protection or ServiceDesk

  1. In a Symantec Management Platform 7 Console, go to Home > IT Analytics.
  2. Click to expand Settings > Connection.
  3. Click on Symantec ServiceDesk.
  4. Enter the name of the ServiceDesk server in the ServiceDesk Database Server Name field.
  5. Enter the name of the ServiceDesk database in the ServiceDesk Database Name field. Note: By default, this is Ensemble for SD 7.0 and ProcessManager for SD 7.1.
  6. Enter SQL server user account for the ServiceDesk Database Username field. Note: A domain user account cannot be used.  As a SQL account use any which has following permissions: public and db_datareader under User Mappings. NB! This account does not mandatory have to be SA account.
  7. Enter the password for above account into the ServiceDesk Database Password and ServiceDesk Database Password Confirmation fields.
  8. Click on the Create button. The message "The ServiceDesk Connection has been added." should appear. Note: The username and password fields on the configuration window are cleared when a configuration is created or saved. This is as working as designed for security purposes.
     

Enable Remote Connections on the Endpoint Protection or ServiceDesk's SQL Server

On the Endpoint Protection or ServiceDesk Microsoft SQL Server, right click on the server name and navigate to Properties > Connections and make sure that "Allow remote connections to this server" box is checked. These instructions are same for both SQL 2005 and SQL 2008. Note: This is normally not needed to be performed.

SQL Server 2000 is not a supported SQL Server for IT Analytics to use. Trying to do so will result in a linked server error.
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Error "Error occurred attempting to add Linked Server." occurs when trying to use a Windows user account to configure the IT Analytics Symantec Endpoint Protection or ServiceDesk connection
https://knowledge.broadcom.com/external/article?legacyId=TECH168582


How to install, configure, use and troubleshoot IT Analytics
https://knowledge.broadcom.com/external/article?legacyId=HOWTO39470

Applies To

IT Analytics 7.x
IT Analytics 7.x Symantec Endpoint Protection Pack
IT Analytics 7.x ServiceDesk Pack