IT Analytics time out when connecting to Reporting Server
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IT Analytics time out when connecting to Reporting Server

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Article ID: 154156

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Updated On:

Products

IT Analytics

Issue/Introduction

The following error is thrown when saving configuration changes to IT Analytics (ITA) in the ITMS console:

Server Error in 'Altiris/IT Analytics' Applications - Request Timed Out

As a result, configuration of ITA fails.

Environment

Version : 7.x, 8.x

Cause

 This error is caused by an underlying ASP.NET process taking longer to complete than the standard 90-second timeout. This behavior is explained in Microsoft KB article 852739:

"This error occurs only when you run the Web application in release mode, and the value of the Debug attribute in the web.config file is set to false.

...

By default, the value of the executionTimeout attribute is set to 90 seconds in the Machine.config file. This error occurs when the processing time exceeds 90 seconds."

Resolution

Increase the timeout setting for ASP.NET processes. The procedures to do this is provided in Microsoft KB article 852739:

Request timed out error when you use the DataAdapter method in an ASP.NET application
https://learn.microsoft.com/en-US/troubleshoot/developer/webapps/aspnet/site-behavior-performance/request-timed-out-dataadapter

NOTE: URL last validated on June 5, 2023