Symantec Critical System Protection (SCSP) or Symantec Data Center Security (DCS) agents offline
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Symantec Critical System Protection (SCSP) or Symantec Data Center Security (DCS) agents offline

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Article ID: 154921

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Updated On:

Products

Critical System Protection Data Center Security Server Data Center Security Server Advanced Data Center Security Monitoring Edition

Issue/Introduction

Large number of Symantec Critical System Protection (SCSP) or Symantec Data Center Security (DCS) agents go off offline. This includes both Windows and Unix agents. This issue occurs on older and newer versions of the agents.

A red circle icon appears in the management console GUI and the agent is not reporting events to the management server.

sis-agent.log error: 

[ERROR] [SQL:9002] The transaction log for database SCSPDB is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases
java.sql.BatchUpdateException: The transaction log for database or SCSPDB is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases
sis-console.log error: 
[ERROR] [LoginHandler:524] [SQL:9002] The transaction log for database SCSPDB is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases
java.sql.BatchUpdateException: The transaction log for database SCSPDB is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

Environment

Applies To

Environment:
• SCSP 5.x, 6.x, 7.x, 8.x
• DCS 6.x
• Windows(R) Server All Versions

Cause

The issue is related to the transaction log in the database being full. Because it is full no new data can be inserted or updated. This is causing the agents to go offline and not allowing the agent to report events to the manager.

Resolution

Steps to backup the database and shrink the transaction log:

First back up the database (steps 1-5)
1. Use ‘sa’ username to login to SQL Server Database using SQL Server Management Studio
2. Expand Databases, and select SCSPDB database
3. Right click the database and select Tasks->Backup
4. Select Backup Type as Full
5. Click on Add and select a backup destination on an external disk
• This will back up the entire database and might take a while to execute
• Please ensure that you have sufficient amount of disk space on external drive
• Press OK

How to shrink the transaction log (steps 6-13)
6. Right-click the SCSPDB database, and then click Properties, which opens the Database Properties dialog box
7. In the Select a Page pane, click Options
8. The current recovery model is displayed in the Recovery model list box
9. Change Recovery model from Full to Simple. Press OK
10. Right-click the SCSPDB database, and then select ->Tasks->Shrink->Files
11. Change File type from Data to Log. Ensure that:
• Filename is changed to scsplog
• File location ends with SCSPDBlog.ldf
12. Set Shrink action to Release Unused Space. Press OK
• The above steps should shrink the transaction log. Verify the transaction log file size on disk
13. Repeat steps 6 to 9 and set recovery model back from Simple to Full after you have increased the available disk space to handle the transaction log size

PLESE NOTE: We strongly recommend that the memory on the servers is increased to at least 4GB each. This is not causing a real problem, however you will find that the systems will perform better if this is done

Once you have resolved the issue, It is recommended that you add this to your database maintenance plan