Installing Altiris client plugins fail with error 1603
search cancel

Installing Altiris client plugins fail with error 1603

book

Article ID: 154950

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Installing Altiris agent plugins fails with error 1603

Installation failed 1603
Error 1603: A fatal error occurred during installation.

Environment

ITMS 7.x, 8.x

Cause

There are multiple possible causes:

  • The destination folder for the Windows Installer package is encrypted.
  • The drive that contains the destination folder for the Windows Installer package is accessed as a substitute drive.
  • The SYSTEM account does not have Full Control permissions on the destination folder for the Windows Installer package. The Windows Installer service uses the SYSTEM account to install software.
  • The System doesn't have the latest version of the MSI installer.
  • The System TEMP and TMP variables are not set to the default path C:\windows\temp.

Resolution

Depending on the cause, try one of the following solutions:

  • Install the package to a folder that is not encrypted
  • Install the package to a drive that is not accessed as a substitute drive


    To grant Full Control permissions to the SYSTEM account, follow these steps:
    1. On the Windows desktop, double-click My Computer. The My Computer window appears.
    2. Right-click the drive desired for the Windows Installer package, and then click Properties.
    3. Click the Security tab.
      Note If Security tab is unavailable, the Simple File Sharing feature is turned on. Turn off this feature to continue.
    4. In the Permissions section, click to select the Full Control check box under Allow, and then click Advanced.
    5. Wait for the operating system to apply the permissions selected to all child folders.
    6. Run the Windows Installer package.
    7. Update the Windows Installer to the latest version using Windows Update.
    8. Set the System Variables for TEMP and TMP to the default value of C:\Windows\TEMP
    9. Right click on My Computer > Properties > Advanced > Environment Variables, and change the value in System Variables for TEMP and TMP to the default C:\Windows\Temp
  • Ensure the agent machine has the latest version of the MSI installer
  • Set the System TEMP and TMP variables path to C:\windows\temp