Troubleshooting "Connection Failed" Messages when Configuring LiveUpdate Administrator 2.x Distribution Centers
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Troubleshooting "Connection Failed" Messages when Configuring LiveUpdate Administrator 2.x Distribution Centers

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Article ID: 155528

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Difficulty is encountered when configuring a remote Distribution Center (DC) for use with a LiveUpdate Administrator 2.x (LUA 2.x) server.   What are the common points of failure?

Messages displayed when connections are tested::

"Connection failed." instead of the desired "Connection to <Server Name> was successful." (if lua2313_test is the name of the remote DC)

 

Cause

One LiveUpdate Administrator 2.x server is usually all that is required, even in large environments.  A well-resourced LUA 2.x server can successfully distribute contents in up to one hundred Distribution Centers (DCs) throughout the corporate network.  Endpoints and other Symantec products can then download their necessary updates from these convenient DCs.

LUA 2.x has capabilities built-in to ensure it can communicate with its DCs.  When "test connection" is clicked in the LUA console, the LUA server will attempt to post a small file called minitri.flg to the Distribution Center using the configuration provided.  

There are many possible causes of failure, but the most common are (1) misconfiguration of the path, and (2) permissions.

 

Resolution

Recommended Resources

Links to the official Symantec knowledge base articles on creating DCs can be found at the bottom of this page.  Following these procedures will enable a remote DC to be created. 

There is also an excellent illustrated article in the Symantec Connect forums on Configuring Distribution Center in LUA (https://www-secure.symantec.com/connect/articles/configuring-distribution-center-lua) - merely examining how a LUA 2.x server's example DC was correctly configured will help to confirm the correct procedure has been followed.

 

Is the URL Correct-? 

One very common cause of failure is that the path to the DC, as configured in the LUA, is wrong.  Navigate to the "Edit Distribution Center" screen, and simply copy the URL and paste it into the address bar of an internet browser window.  Does that URL actually exist?  Can that configured URL be accessed and opened from this computer?  

Misconfiguration is common, especially if the DC is a new HTTP or FTP site hosted on a remote IIS server.  (When creating a new site on an existing IIS server, a unique port number must be used.  Attempting to connect to the pre-existing IIS server site's default port 80 will fail.)  In the example shown below, the IP and port were corrected for the environment, and the status of this DC changed to "Ready." 

 


Logs from the Remote DC 
Examining the LUA server's logs alone will not provide all the answers.  Assuming that the remote DC is on an IIS server with IP <Remote DC>: examining that IIS server's logs may provide some clues. (Also consult Microsoft's article: The HTTP status codes in IIS 7.0 and in IIS 7.5 to learn what the code numbers mean!)

Example logs from a failed connection attempt:

2011-12-05 15:25:38 <Server Name> <Remote DC> HEAD /LUAtypoDC/ - 4807 - <IP Address> HTTP/1.1 LiveUpdate+Administrator 404 0 2 156
2011-12-05 15:25:38 <Server Name> <Remote DC> HEAD /LUAtypoDC/ - 4807 - <IP Address> HTTP/1.1 LiveUpdate+Administrator 404 0 2 125
2011-12-05 15:25:38 <Server Name> <Remote DC> HEAD /LUAtypoDC/ - 4807 - <IP Address> HTTP/1.1 LiveUpdate+Administrator 404 0 2 109

In this case: there was a misconfiguration.  When the administrator attempted to configure the DC ("Edit Location" screen), they entered in a "Root Directory" called "LUAtypoDC."  These IIS logs show that when the LUA server attempts to test the configured connection, it cannot find any directory of that name.  

In the example below, examining the IIS log made it clear that the username was entered incorrectly in the LUA console:

2011-12-06 10:02:49 <Server Name> <Remote DC> PUT /minitri.flg - 4807 wrongname <IP Address> HTTP/1.1 LiveUpdate+Administrator 401 1 1326 0
2011-12-06 10:02:49 <Server Name> <Remote DC> HEAD / - 4807 - <IP Address> HTTP/1.1 LiveUpdate+Administrator 200 0 0 46 

For comparison, here is an IIS log entry from a successful test:

2011-12-05 15:26:40 <Server Name> <Remote DC> PUT /minitri.flg - 4807 domainname\<Username> <IP Address> HTTP/1.1 LiveUpdate+Administrator 201 0 0 46
 

Too Much Information

Not all of the fields are manditory on the "Edit Location" screen where the DC is configured.  If the contents are not located in a subdirectory, leave "Root Directory" blank.  If a proxy server is not involved, leave those fields blank.  

When supplying "login credentials for distribution access to remote location," it is generally just necessary to provide the username.  Attempts to also add the domain name may cause the connection attempt to fail.

 

Playing with the Proxy 

After any changes are made to the proxy configuration (Configure > Source Servers), stop and restart the LUA Tomcat service of the LUA 2.x server.  This will confirm that new credentials and other details about the proxy are in effect at all levels of networking.  Changing proxy-related details in the GUI and saving them is not sufficient. 

 

If Technical Support's assistance is required:

This is one of the few situations where it is preferable to put the LUA 2.x server into DEBUG: ON mode.  By default, the lua-application logs will record only if there was a success or failure without any extra details.

Example of a failed connection with DEBUG off:

2011-12-05 15:07:31,000 [http-apr-/<IP Address>-7070-exec-23] INFO config.ConfigManagerUtil - testServerConnection(Production/Test server) returns:false , server name: <Server Name>

Example of a failed connection with DEBUG on (MUCH more information on what configuration LUA is trying to use):

2011-12-05 15:07:30,985 [http-apr-/<IP Address>-7070-exec-23] DEBUG config.ConfigManagerUtil - start testServerConnection(BaseServer server)ProductionServer ( BaseServer (<Server Name> id = 8 name =<Server Name> username = <Username> connectionStatus = null deleted = false updatedTimeStamp = null connectionInfo = ConnectionInfo ( <Server Name> id = 8 hostName = <Server Name> Port = 4807 protocol = HTTP contentDir = LUAtestDC login = domainname\<Username> readOnlyLogin = proxyName = null proxyPort = null proxyProtocol = null proxyUser = null usingWriteOnlyLogin = true ) serverType = LUA_PRODUCTION_SERVER ) productionServerGroup = 4 )
2011-12-05 15:07:30,985 [http-apr-/<IP Address>-7070-exec-23] DEBUG config.ConfigManagerUtil - testServerConnection(Production/Test server) 
2011-12-05 15:07:31,000 [http-apr-/<IP Address>-7070-exec-23] DEBUG rcl.HttpHelper - httphelper open start : Mon Dec 05 15:07:31 GMT 2011
2011-12-05 15:07:31,000 [http-apr-/<IP Address>-7070-exec-23] DEBUG rcl.HttpHelper - httphelper open executed : Mon Dec 05 15:07:31 GMT 2011
2011-12-05 15:07:31,000 [http-apr-/<IP Address>-7070-exec-23] INFO config.ConfigManagerUtil - testServerConnection(Production/Test server) returns:false , server name: <Server Name>

If it is necessary to contact Symantec Technical Support, please place the LUA server in DEBUG: ON mode, reproduce the connection attempt, and turn debugging back off.  Be sure to collect all of the information specified in How to Collect Troubleshooting Information from LiveUpdate Administrator 2.x.