Error "Server Error in '/Altiris/ITAnalytics' Application" occurs when trying to open the IT Analytics Configuration page
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Error "Server Error in '/Altiris/ITAnalytics' Application" occurs when trying to open the IT Analytics Configuration page

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Article ID: 155791

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Updated On:

Products

IT Analytics

Issue/Introduction

When trying to open the IT Analytics Configuration page, found by going to the Settings button > Notification Server > IT Analytics Settings > Configuration, the page displays a server error and fails to load. This prevents IT Analytics from being re-configured.

Other symptoms may include being unable to process cubes, install or uninstall cubes or access reports. Other errors may appear such as being unable to connect to the server.

Server Error in '/Altiris/ITAnalytics' Application

Cause

Something was changed or deleted on either or both of the SQL Server Analysis Server (SSAS) or SQL Server Report Server (SSRS). IT Analytics is no longer able to access these and fails to be able to be configured. 

Resolution

WARNINGS:

(1) This article is intended only to be ran by the Symantec Technical Support engineer for the customer as this may be a complicated process. If a customer is performing these steps instead, please ensure that all steps are clearly understood before continuing.

(2) This article is intended as a last resort to repair a broken Configuration. It is strongly recommended to not reset the SSAS by using the included script unless used for the specific issue as described in this article. Doing so may result in additional issues if implemented unnecessarily. For all other issues using ITA or setting up its configuration and connections, refer to other articles, such as the following, instead:

Error "Analysis Server 'server name' does not exist." occurs when trying to configure IT Analytics
TECH198904

(3) This is also an unofficial solution and SQL script to resolve this issue. Use at your own risk. The customer is recommended to back up their database in the case issues occur from using this script, as IT ANALYTICS DATA LOSS MAY OCCUR.
 
Troubleshoot the Item table's ITA values for the SSAS and SSRS

 

  1. The cause of the issue will need to be determined before a solution can be suggested. The important thing to note is the full name of the error, which appears under the "Server Error" error. Various related articles can be found in the Symantec Knowledge Base that discuss specific issues. Review these first by searching for the specific error in the Knowledge Base before continuing here with this article.
  2. If no specific articles are found in the KB, next use the included SQL script "Find ITA SSAS and SSRS data.txt" to run against the Symantec_CMDB database that IT Analytics is installed to. This will display what was entered as the Analysis Server Name, Analysis Server Database, Reporting Server Virtual Directory URL and Report Folder Name. If any of these are renamed or deleted in SQL, this can result in this issue. If the script returns no results, then this indicates that ITA has not saved an SSAS/SSRS. Skip the remaining instructions and instead use the following article to continue troubleshooting the issue:

    IT Analytics cubes fail to process
    TECH200974
     
  3. If  the SQL script "Find ITA SSAS and SSRS data.txt" returns results, are these correct? The user should know what to expect for valid names. It's possible then that these are different names that the user isn't expecting. This indicates that most likely (as previously mentioned), the SSAS or SSRS were renamed or deleted.
  4. If it is suspected at this time that there is a discrepancy between what is found by the SQL script "Find ITA SSAS and SSRS data.txt" and what should be set in ITA, the user can modify or delete this entry to help enable ITA to be able to access its Configuration page once again. The SQL script "Reset ITA SSAS and SSRS data.txt" (which is an internal link to this article) can reset this. Please contact Symantec Technical Support to obtain this SQL script.


Troubleshoot the Report Server 

  1. For Report Server troubleshooting, can the Report Server Virtual Directory URL be accessed by a browser? By default, this is http://<server_name>/ReportServer. If this was changed in Microsoft Reporting Services Configuration Manager or not available, this will result in an error trying to access this page. Depending on the issue's cause, solutions include:
     
  • If something was renamed in SQL/Microsoft Reporting Services Configuration Manager, change this back to how it appears from the SQL script.
  • If something was deleted in SQL, recreate this if possible, such as the report folder. This may then enable access to the Configuration page, but not have expected data. For the same example, if the report folder is recreated, IT Analytics reports will need to be reinstalled to place their data back into this. If so, it is recommended to uninstall and then reinstall any report packs in the Symantec Installation Manager, then reinstall the cubes and reports in IT Analytics. This should rebuild the missing report data and subfolders.
  • After making changes in SQL/Microsoft Reporting Services Configuration Manager, the SSAS or SSRS services and IIS may need to be restarted on the SQL Server for this to take effect.
  • In addition, ensure that the SSAS and SSRS services are started on the SQL Server. Having this stopped should not result in this issue, however, will result in other issues when trying to use IT Analytics.
  • Also attached to this article is the SQL script "Reset ITA SSAS and SSRS data.txt". This works similarly to the "Find" script in that it also finds the ITA configuration. This script will also enable the user to clear the SQL entry for this, which can often successfully reset the ability to access the IT Analytics Configuration page.
     
  • Reset the SSAS database file folder that ITA uses. The following article describes how to do this:

    How to reset the Microsoft SQL Server Analysis Server database file folder
    HOWTO75065


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