CMDB task "Inventory to Asset Synchronization" does not sync the System Number
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CMDB task "Inventory to Asset Synchronization" does not sync the System Number

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Article ID: 156286

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Updated On:

Products

Inventory Solution CMDB Solution

Issue/Introduction

When running the CMDB task "Inventory to Asset Synchronization" (Manage > Jobs and Tasks > Service and Asset Management > CMDB > Inventory to Asset Synchronization), the task syncs Serial Number, Manufacturer and Model, but not the System Number.

Cause

The Inventory to Asset Synchronization task looks for the Inventory Solution System Number (a.k.a., Asset Tag) data in the Inv_SW_BIOS_Element.[Identification Code] data class. However, some hardware manufacturers do not provide data in WMI for this data class. This will result in the sync failing to populate any data into CMDB's System Number data class as the source data class is empty.

Resolution

First, verify whether or not the Inv_SW_BIOS_Element.[Identification Code] data class is selected for collection in your inventory policies.

 

Navigate in the console to Manage > Policies > Discovery and Inventory > Inventory and find your applicable inventory policies. The default policies would be Collect Full Inventory and Collect Delta Hardware Inventory. In each policy, navigate to Advanced, and in the pop-up window, go to the Data Class tab > Inventory data classes > Software > Common and verify that BIOS Element is selected with a green check mark, then click OK. Ensure that the desired computers are listed in the Applied to section and show as having ran a successful inventory. If the BIOS element was not enabled or an inventory has never run on your test computer, run an inventory task/policy followed by the Inventory to Asset Synchronization task before moving on to ensure that the solution below does in fact apply in your environment. See the related documents on the Inventory to Asset Synchronization for more information on what is happening with this process.

 

Once you verify that inventory is not populating the data classes involved, move on to the next section.


A workaround is to change the Inventory to Asset Sync's stored procedure, "spAssetInventorySync", to use the alternate Inventory Solution data class desired and not the default one to correctly populate the CMDB System Number data class.

  1. Determine what Inventory Solution data class is to be used by the Inventory to Asset Synchronization. Known fields include:

    Inv_SW_BIOS_Element.[Identification Code] (default)
    Inv_HW_Chassis.[Asset Tag]
     
  2. Modify the stored procedure "spAssetInventorySync" to change the source field to be where the data is located at. Note: An example of an already-modified version of this stored procedure is available as an attachment to this article and is already set to use the Inv_HW_Chassis.[Asset Tag] data class. Please contact Technical Support if you would like to have this example modified version be set to go to a different data class other than the two listed above.
  3. Run the Inventory to Asset Synchronization task after the stored procedure was modified and saved. The correct System Number should now be copied to the CMDB System Number data class if it is not populated.


Related Articles

How does the CMDB task "Inventory to Asset Synchronization" work?


How to troubleshoot the CMDB task "Inventory to Asset Synchronization"

 

Applies To

 

CMDB 8.x
Inventory Solution 8.x

Attachments

spAssetInventorySync.sql get_app