LUA 2.3.x no longer downloads new content as different symptoms when using Symantec's proxy server
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LUA 2.3.x no longer downloads new content as different symptoms when using Symantec's proxy server

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Article ID: 157674

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Sometimes it is found that LUA download the definition failure with different symptoms or different errors logged. When checking the LUA default downloads folder, you find that all files exist with the old timestamp. If the SEPM LiveUpdates from this LUA, it will show not the newest definitions available. When cleaning the content or reinstalling/redownloading, different symptoms appear.  This issue only relates with LUA going through proxy server.

  • Some similar symptoms:
    • Not any obvious error in LUA log, but SEPM could not LiveUpdate successfully from it.
    • When LUA downloads definition manually, it shows that not newest definition available and the download process window does not appear.
    • If download all content, sometimes it could show download process window ,but download 70%(or other percent),it will show fail warning message at last.
    • Even if download successfully , but if check the downloads folder, it often is only about 100MB(if fresh install LUA and first download)
    • If adjust some parameter to increase the LUA performance, issue still exists.
  • Error LUA application log:
    • ERROR rcl.HttpHelper  - Fatal transport error in download: 404: could not find file to download -           http://liveupdate.symantecliveupdate.com:80/1358139475jtun_irev130111007.7z.....................
    • ERROR rcl.SegmentedDownloader  - Exception while download of file1360622372jtun_sep12en130128017.m26    org.apache.http.conn.ConnectionPoolTimeoutException: Timeout waiting for connection.

Cause

The old cache of the proxy server isn't cleaned in time and kept active. When LUA requests the update, it will obtain the out-of-date package or miss some content. The Symantec proxy server may cache old files and provide them to LUA as if they were current.

Resolution

Workaround 1 (This is the preferred workaround):

  Clean the cache or temp download folder of proxy server.

  Within the Symantec proxy, change the criteria upon which Symantec proxy judges files to be up-to-date or OK to expire. 


Workaround 2 (Optional workaround. The first change is always useful and but might take several days):

  Change any of the failover LiveUpdate servers to the primary LiveUpdate server (ensure the failover server is ready)

   1.Go to Configure -> Source Servers, select the Symantec LiveUpdate and Edit.

   2.Select any failover LiveUpdate server, then click Primary.

   3.Click OK button to save.

   4.Restart LUA tomcat service.

   After these changes, sometimes there will still be a download failure. Check the log for a timeout error, then resolve it by increasing the below values of timeout, retry, and retry interval in the LUA configuration (Open the LUA console, click on Configure, then Preferences. Scroll down to Server Connections) to improve the chance of successful connections.

 TIMEOUT: 120 seconds
 RETRY: 5
 RETRY INTERVAL: 10 seconds.

If still could not resolve this issue by these two workarounds, please contact a Symantec support engineer and request more help. 

 

Applies To:

LUA 2.3.2.99 or 2.3.1.82

Symantec proxy server.