Software Inventory does not Detect Some Versions of Internet Explorer
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Software Inventory does not Detect Some Versions of Internet Explorer

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Article ID: 158244

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Updated On:

Products

Inventory Solution

Issue/Introduction

Software inventory does not detect newer versions of Internet Explorer. Also Software Inventory may not detect older versions of Internet Explorer.

Environment

ITMS 8.x

Cause

Software Inventory cannot detect Internet Explorer (IE) versions 9 and above because these newer versions of IE are installed differently. They do not create the uninstall registry keys that are scanned by Add or Remove Programs and Software Inventory.

Resolution

Instead of searching for Add/Remove programs registry keys the iexplore.exe file can be scanned to detect Internet Explorer (IE). This can be accomplished using Targeted Software Inventory (method 1), File Inventory (method 2), or Custom Inventory (method 3). 

Method 1: Targeted Software Inventory – this inventory allows different versions of IE to be reported the same way as normally inventoried software products but is much more complicated than File Inventory (method 2).

Step 1: Create a new software release for IE

  1. In the Symantec Management Program (SMP) console, navigate to Manage>Software Catalog.
  2. In the Software Catalog window, on the left under Newly discovered/undefined software, click on the Add button and select Software Release.
  3. Name the new software release for the version of IE to be detected, such as Internet Explorer 11. For multiple versions of IE such as 8, 9, 10, and 11, create a new software release for each and repeat the following steps for each.
  4. In the Properties tab, add appropriate entries for Version (such as 11.0) and Company (Microsoft).
  5. In the Rules tab, click New on the Detection rule line.
  6. Name the rule (such as IE 11 Detection Rule).
  7. Click the blue + button then select Operators>Or.
  8. Select the Or operator that was just created under the And operator.
  9. Click the blue button to add a new expression. Select Standard Rule>File Version
  10. In the File path box, add the path (no quotes) to the IE executable file: C:\Program Files\Internet Explorer\iexplore.exe
  11. Change Version type to Product Version.
  12. Select an operator for the Version must be option. For example, for IE 11, use [ ] and enter 11.0 in the left and 11.99 in the right text boxes.
  13. Click OK to close the File Version window.
  14. Repeat steps 9 through 13 to create another File Version rule under the Or operator but this time specify this alternate path to the IE executable file: C:\Program Files (x86)\Internet Explorer\iexplore.exe
  15. Click OK to close the Create Rule window, and click OK to close the software release window.

Step 2: Create a new Targeted Software Inventory

  1. Navigate to Manage>Policies>Discovery and Inventory>Targeted Software Inventory.
  2. Right-click on the Targeted Software Inventory folder and select New>Targeted Software Inventory.
  3. Click on the name field and rename it appropriately, such as IE 11 Targeted SW Inventory.
  4. In the Software to Inventory section, click Select Software.
  5. In the Select Software pop-up window, search for the IE software release(s) created in Step 1 and move it(them) to the right with the > button. Note there may be other IE software releases with the same name but with the wrong version (1.0), don't choose these.
  6. Click OK to close the Select Software window.
  7. In the Schedule section, click Add schedule to add an appropriate schedule; for example, select Scheduled time, set Start to 10:00, click No Repeat, and choose Repeat Every: Day.
  8. In the Applied to section, either leave the default target to inventory all clients with the inventory plug-in, or delete this target and click Apply to to create a more limited target.
  9. At the top, click on the red Off button and select the green On option.
  10. Click Save changes.

Step 3: View the Targeted Software Inventory Results

  1. After the Targeted Software Inventory policy runs go to Reports>Discovery and Inventory>Inventory>Cross-Platform>Software\Applications>Software>Installed Software to see which computers were detected with IE installed.
  2. Or go to Manage>Software, click on Software Releases, and the software releases created in Step 1 will now be visible if they were detected on inventoried machines. Click on the IE software release and the Computers with software installed section will show a list of computers that the Targeted Software Inventory detected IE on.

 

Method 2: File Inventory – this method utilizes data collected by File Inventory to detect the presence of IE on inventoried computers and collect version information. This will not display IE as a software product in various places as Targeted Software Inventory (method 1) would, but IE will show up in various default reports or the attached custom report. Beware that File Inventory is much more CPU intensive on client computers and causes more network traffic than Targeted Software Inventory (method 1).

To setup File Inventory:

  1. Navigate to Manage>Policies>Discovery and Inventory>Inventory.
  2. By default File Inventory is already enabled in the Collect Full Inventory policy; either use this default policy, create a new policy for File Inventory, or edit a currently used inventory policy to enable File Inventory within it.
  3. In the Inventory policy ensure that the File properties - manufacturer, version, size, internal name, etc. option is enabled, this is File Inventory.
  4. After the File Inventory has run, navigate to Reports>Discovery and Inventory>Inventory>General Software>Audit Software Search report to view the inventory results.
  5. Modify the Parameters section to display the desired results, for example set *File Name: to iexplore.exe and Product Version: to 10% to show computers with IE 10. Click Refresh in the grey title bar of the report after changing the parameters.
  6. Alternatively, save the attached custom report to the notification server, then open Reports>All Reports and navigate to a folder where this report will be saved. Right click on that folder and select Import. Browse to the location where the attached report is downloaded, select it and click Open. Note: this report is not supported by Symantec and futher modifications must be done by the user.

Method 3: Custom Inventory – This is the fastest and most reliable method but requires the most customization. Please find the attached custom inventory vbscript and follow KB 178799 for instructions on setting up the custom inventory.

 

Attachments

IEVersionCustomInventory.vbs get_app
Computers with Internet Explorer 7 - 11.xml get_app