Error: "This query was halted before completion - Query timed out in command execution" in CCS
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Error: "This query was halted before completion - Query timed out in command execution" in CCS

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Article ID: 164007

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Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Server

Issue/Introduction

Control Compliance Suite (CCS)

CCS on Unix times out with error: This query was halted before completion -  Query timed out in command execution.

Query timed out in command execution.

Environment

Running a Data Collection/CER/Query on Unix via agent-less or agent-based.

Cause

Either the job is taking to long due to the number of assets, or due to the amount of data on the assets.

Resolution

This applies to CCS 12.x.

Please modify the following file on all CCS Managers. (Drive and path may be different based on where the CCS Manager was installed at)

C:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\DPS\control\Unix\ConfigFiles\ConfigSettings.ini

  • CompositeDescGroupLen=5
  • QueryTimeOutSeconds=3600
  • MaxThreads=30
  • SSHConnectionTimeout=180000
  • ThreadsPerTarget=10
  • AllowLocalUsersAndGroupsOnly=1
  • CommandOutputTimeOutSeconds=3600

 

NOTE: The entry "CommandOutputTimeOutSeconds=3600" does not exist in the config file by default, and will need to be added manually.

.

  1. Modify the two timeout parameters highlighted above as needed.  The values are in seconds.
    1. The QueryTimeOutSeconds parameter will timeout the job regardless of what is going on at XXXX seconds.  Default is 3600 seconds (1 hour).
    2. The CommandOutputTimeOutSeconds parameter will timeout if any specific command is still running after XXXX seconds.  Default setting is 3600 seconds (1 hour).
  2. It is recommended to double the number of seconds (increase from 3600 seconds to 7200 seconds, etc.) to see if that allows enough time for the scan to complete.  For some UNIX\Linux filesystems, you may need to increase the time to 6 or 8 hours for the scan to complete successfully.  
  3. Stop and restart the 'Symantec CCS Manager' service and the 'Symantec Data Processing Service' service for those updated configuration settings to take effect.

NOTE: If the job is still reporting this error after increasing the timeouts above, and you have increased the parameters above to 6 or 8 hours to complete the data collection and it still does not complete, then you might need to break the CCS Standard into smaller sections and run each section individually so it will complete in a reasonable amount of time.