Changes in the mail attribute field in Active Directory triggers a deletion in Schemus
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Changes in the mail attribute field in Active Directory triggers a deletion in Schemus

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Article ID: 164298

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Updated On:

Products

Email Security.cloud

Issue/Introduction

The LDAP Synchronization Tool is adding email addresses to the deletions column when the mail attribute is changed in active directory under the user record. This can occur when using Exchange Online as the data source in Schemus.

Environment

  • Schemus ver. 1.50

Cause

Schemus by default uses the %mail% variable to copy the value of the mail attribute from the LDAP server to the destination attribute for each record as this is usually the primary SMTP address.

Note:  This attribute is not maintained by Exchange as it is an AD attribute and therefore it can have any value or can even be empty.

Resolution

If there is a need to change the Mail attribute value for the active directory user record(s).

The primary mail can be changed from %mail% to %proxyAddresses{s/(SMTP:|.*:.*)(.*)/$2/}% in the schemus configuration by following these steps:

  1. Open Schemus
  2. Select the configuration
  3. Click on Configuration at the top menu
  4. Click on Modify
  5. Make sure the "Mail" Synchronization type is selected
  6. Click on LDAP Search at the left menu
  7. Click on Advanced...
  8. Delete the variable %mail% from the Primary Mail input box
  9. Then type %proxyAddresses{s/(SMTP:|.*:.*)(.*)/$2/}% in the same input box
  10. Click on Next and Save.

By defining 'SMTP' in uppercase, this indicates that the primary email address would be extracted from the proxyAddresses attribute. This is the same under Mail Aliases but using the ‘smtp’ in lowercase which would also extract the aliases.