Configuring Protection for SharePoint Servers to bind to a different IP address when multiple nics are present
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Configuring Protection for SharePoint Servers to bind to a different IP address when multiple nics are present

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Article ID: 164341

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Updated On:

Products

Protection for SharePoint Servers

Issue/Introduction

Your SharePoint servers have multiple nics or multiple IP Addresses. In the CA console farm overview, one or more servers with Symantec Protection for SharePoint Servers (SPSS) show "Stopped." Registering scanners hangs or times out.

There may be a hosts file with an entry different than the IP address that SPSS binds to.

If your server does not have multiple nics or IP Addresses, see the following article:

https://knowledge.broadcom.com/external/article/164011/

 

 

Cause

SPSS is dependent on both forward and reverse DNS, which are not working as expected with the multiple IP addresses or nics.
 

Resolution

Correct the DNS issue or remove the Host file Entry.

Work around:

Please follow the below steps to bind the IP address.


Steps:

  1. Change the primary NIC to the one that is desired and disable the other one. Get the IP Address for the newly set NIC using ipconfig command.
  2. Open the config file “Symantec.Sharepoint.SPSSService.exe.config” at the location “<Drive Letter>:\Program Files\Symantec\SharePoint” where <Drive Letter> refers to the drive where SPSS is installed. Please create a backup of the file before making changes.
  3. Enter the below entry in the “<appSettings>” section and save the config file. Here the “<New IP Address>” refers to the IP Address noted in the step #1.
    <add key="bindToAddress" value= "<New IP Address>"/>
    Above tag is optional, which doesn’t automatically come with SPSS 6.0.4 installation. Customer has to add this entry with the IP address they wants to bind to.
  4. Restart the “Symantec Protection 6.0 for SharePoint Servers” service of all WFE servers followed by the CA server
  5. Check the “SPSSObjects” table in the database and verify that the new IP Address is being reflected for “SPSSEnabledServer” ObjectType. Use the following query to get the same.
    select * from SPSSObjects where ObjectType = 'SPSSEnabledServer'
  6. Check if the web.config file located at installation directory “<Drive Letter>:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\ADMIN\Symantec” is added  with the new IP Address specified as value of ‘bindToAddress’. Below are sample entries for the same:
    <add key=" New IP Address _RTCommandChannel" value="9455" />
    <add key=" New IP Address _ReportingChannel" value="9466" />
    <add key=" New IP Address _LoggingChannel" value="9477" />
  7. Check if SPSS is working fine now as per the customer’s requirement.