Certain files are called unscannable when content filtering is enabled to scan Attachment Content, Any Part, or a File Type Filtering rule is enabled
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Certain files are called unscannable when content filtering is enabled to scan Attachment Content, Any Part, or a File Type Filtering rule is enabled

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Article ID: 164353

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Certain files are called unscannable when content filtering is enabled to scan Attachment Content or Any Part with Symantec Mail Security for Microsoft Exchange (SMSMSE). An application crash of the process SAVFMSESp.exe is logged to the application event log, along with an Event ID 218 calling the item being processed at the time Unscannable.

 

If a Debug log is obtained while reproducing the problem (See 'How to Obtain Debug Logs for Symantec Mail Security for Microsoft Exchange (SMSMSE)' for detailed instructions), the following is observed at the time of the crash:

[11052] SAVFMSECtrl(2B2C)[17B4] 2016-01-26 20:26:04 0834ms:
[11052] ..\..\..\src\Server\SAVFMSELINK\ctrlintf.cpp(1155) :
[11052]  Debug Trace: HRESULT=0x6d
[11052] 
[11052] SAVFMSECtrl(2B2C)[17B4] 2016-01-26 20:26:04 0834ms:
[11052] ..\..\..\src\Server\SAVFMSECTRL\Manager.cpp(568) :
[11052]  Debug Trace:  HRESULT=0xC0090086
[11052] 
[11052] SAVFMSECtrl(2B2C)[17B4] 2016-01-26 20:26:04 0834ms:
[11052] ..\..\..\src\Server\SAVFMSELINK\ctrlintf.cpp(919) :
[11052]  Inside NaveLinkInterface SendCommand
[11052] 
[11052] SAVFMSECtrl(2B2C)[17B4] 2016-01-26 20:26:04 0834ms:
[11052] ..\..\..\src\Server\SAVFMSELINK\ctrlintf.cpp(943) :
[11052]  Debug Trace: HRESULT=0xe8

Cause

A problem with the Verity content filtering engine causes crashes when processing certain attachment content.

Resolution

A hotfix has been created to address this issue. 

 

To apply the patch:

  1. Download the attached file 4061389.zip.
  2. Open the Services console and stop the "Symantec Mail Security for Microsoft Exchange" and "Symantec Mail Security Utility Service"
  3. Back up the 'Bin' folder from SMSMSE install folder , default location C:\Program Files (x86)\Symantec\SMSMSE\7.5\Server\Verity
  4.  Copy the 'Bin' folder from the attached zip file to the C:\Program Files (x86)\Symantec\SMSMSE\7.5\Server\Verity directory.
  5. Start the "Symantec Mail Security for Microsoft Exchange" and "Symantec Mail Security Utility Service"

 

Workaround

Disable any content filtering rule(s) set to scan "Any Part" or "Attachment Content" or change the match type to a choice other than "Any Part" or "Attachment Content". Disable any File Type filering rules.

Attachments

4061389.zip get_app