“Error: indexedDataStatus.corrupted_data_file” when indexing a Directory Group
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“Error: indexedDataStatus.corrupted_data_file” when indexing a Directory Group

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Article ID: 164718

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Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

When creating or updating an index on an Active Directory group the job fails.

In the localhost<date>.log file found on a Windows Enforce server at \ProgramData\Symantec\DataLossPrevention\EnforceServer\<version>\logs\tomcat or on a Linux Enforce server at /var/log/Symantec/DataLossPrevention/EnforceServer/<vesion>/tomcat/ the following error can be seen:

"Exceeded the corruption threshold of {1}% while indexing database profile {0}. {2}"

java.lang.Throwable: Too many invalid rowsjava.lang.Throwable: Too many invalid rows

Cause

While the error threshold for Exact Data Matching (EDM) indexes can be adjusted to exceed 0% and invalid rows can be dropped, Directory Group indexes cannot contain any invalid data.

Resolution

1. Enable indexer error logging by opening Indexer.properties located in \Program Files\Symantec\DataLossPrevention\EnforceServer\<version>\Protect\config and updating the value for create_error_file=false to create_error_file=true then restart the SymantecDLPManager service. 

2. Try the indexing job again and then refer to the .err file created in \ProgramData\Symantec\DataLossPrevention\ServerPlatformCommon\<version>\index. That file will show all the invalid values that are preventing the index from being created.

3. Correct the invalid entries found in the .err file and try the indexing job again.

The reason for the invalid data is most likely because the directory group being indexed is too broad and includes service accounts, printers, meeting rooms, and the like. To avoid this problem, try to tailor the directory group connections to specific OUs or user groups.