Incident and message data is not updating in the Enforce Console
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Incident and message data is not updating in the Enforce Console

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Article ID: 164734

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

The incident, message, and traffic data in System > Servers > Overview section do not update.


 

VontuMonitorController.log will show the following:

INFO   | jvm 2    | 2017/03/01 10:09:18 | Caused by: java.lang.OutOfMemoryError: GC overhead limit exceeded
INFO   | jvm 2    | 2017/03/01 10:11:18 | [org.apache.ojb.odmg.TransactionImpl] ERROR: Unexpected failure while locking
INFO   | jvm 2    | 2017/03/01 10:11:18 | Unable to contact lock server at 127.0.0.1:37328.
INFO   | jvm 2    | 2017/03/01 10:11:18 | org.apache.ojb.broker.PersistenceBrokerException: Unable to contact lock server at 127.0.0.1:37328.

Cause

The Java Heap settings in the VontuMonitorController.conf file on Enforce are set too low.

Resolution

This can be caused if the init and max java heap settings in the VontuMonitorController.conf file are set too low:

# Initial Java Heap Size (in MB)
wrapper.java.initmemory = 256
wrapper.java.maxmemory = 512

Change the settings to 1024 and 2048 respectively and restart Monitor Controller on Enforce.

These settings can be increased as needed depending on the amount of RAM on Enforce.
 


Do not increase the memory beyond 31GB.
At 32GB you lose memory compression and it becomes counter-productive.
In most circumstances there are better ways to handle out of memory errors than increasing the memory beyond 31GB.