Server Error in '/Altiris/DiscoveryTasks' Application
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Server Error in '/Altiris/DiscoveryTasks' Application

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Article ID: 164790

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Updated On:

Products

Altiris Network Discovery

Issue/Introduction

If a Network Discovery task is scheduled, then the page gives an error "Server Error in '/Altiris/DiscoveryTasks' Application".

The error appears across different pages on Symantec Management Console, like:

  1. Home> Discovery and Inventory> Network Discovery
  2. Home> First Time Setup> Network Discovery
  3. Settings> Console> Web Parts> Network Discovery Task Management

Server Error in '/Altiris/DiscoveryTasks' Application

Error seen in the Symantec Management Platform (SMP) Log Viewer and on the page:

Failed to enable constraints. One or more rows contain values violating non-null, unique, or foreign-key constraints.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.ConstraintException: Failed to enable constraints. One or more rows contain values violating non-null, unique, or foreign-key constraints.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:

[ConstraintException: Failed to enable constraints. One or more rows contain values violating non-null, unique, or foreign-key constraints.]
   System.Data.DataTable.EnableConstraints() +2707068
   System.Data.DataTable.EndLoadData() +235
   Altiris.TaskManagement.Data.TaskStatusData.GetRawSchedulesForTaskItem(Boolean extended, NSItemGuid taskItemGuid) +2113
   Altiris.DiscoveryTasks.DiscoverTask.GetNextOccurrance() +179
   Altiris.DiscoveryTasks.Web.PortalPages.TaskTypesGrid.ConvertToDataRow(DiscoverTask taskItem) +663
   Altiris.DiscoveryTasks.Web.PortalPages.TaskTypesGrid.LoadTaskTypesData() +442
   System.Web.UI.Control.LoadRecursive() +71
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Control.LoadRecursive() +190
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3178

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Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18408

Environment

Symantec Management Platform 8.0 Hot Fix version 4.

Cause

This is a known issue in SMP 8.0 HF4 version.

Following are the steps to reproduce:

  1. Launch the SMP Console.
  2. Go to Home> Discovery and Inventory> Network discovery wizard.
  3. Click Launch Network Wizard and Schedule a Network discovery for every 5 minutes.
  4. Few minutes later the error appears in Home> Discovery and Inventory> Network Discovery.
     

Resolution

The issue is specific to SMP 8.0 HF4. It is not reproducible in later builds.

Workaround:

  1. Go to Manage> Jobs and Tasks and delete the schedule for this task.
  2. Create a new Network Discovery Task through Actions>Discover> Network Devices. The result of the task can be seen on Manage > Jobs and Tasks Page.