ITMS Monitor Solution Service fails to Install with error code 1603
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ITMS Monitor Solution Service fails to Install with error code 1603

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Article ID: 165006

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Updated On:

Products

Server Management Suite IT Management Suite

Issue/Introduction

The monitor service under site server settings installs three components when it installs: RMS agent, Pluggable Protocols Agent, and Credential Manager. On occasion, a previous install can cause the service to fail to install with exit code 1603. Primarily this occurs with the RMS agent and/or the Pluggable Protocols Agent.

Error 1603 will be displayed in the task status, task history, event viewer application logs, and agent logs when the failure occurs.

The event viewer application logs will generate the following error: Windows installer installed the product. Product Name Monitor Agent for Windows Package. Product version 7.x.xxxx.x. Product Language: 1033. Manufacturer: Altiris. Installation success or error status: 1603. Event ID 1033.

The monitor RMS package will fail with the error:
Product: Monitor Agent for Windows package -- Remote Monitoring Server requires PPA Agent installed.  Setup cannot continue. Event ID 10005

Environment

ITMS 8.x
 

Cause

The exact cause of this error is unknown, but it is always caused by a previous install that did not successfully uninstall.

Resolution

The problem is caused by a partial installation, so try to uninstall the monitor service from the Altiris Console.

  1. Navigate to Settings > Notification Server > Site Server Settings. 
  2. Expand Site Management > Site Servers and select the problematic site server. 
  3. Select Install/remove services. 
  4. Uncheck Monitor service (note: it may already be unselected because of the partial install, please see next steps). 
  5. Go back to Settings > Notification Server > Resource Membership Update.
  6. From here log on to the problematic server do a configuration update and see if both RMS and PPA uninstall correctly. 
  7. If this works try to reinstall the monitor service and see if it fails again. 

If this does not work attempt a manual uninstall/install of the monitor service. 

From the notification server copy down the following MSI's directly to the problematic site server:

  • NS Install Drive:\Program Files\Altiris\Notification Server\NSCap\bin\Win64\X64\Monitor Solution Package\Altiris_MonitorAgentPackage_x64.msi
  • NS Install Drive:\Program Files\Altiris\Notification Server\NSCap\bin\Win64\X64\RMS PPA Agent Package\Altiris_PluggableProtocols_Agent_x64.msi                              

Then in the following order run these commands on the problematic site server to uninstall both the PPA and the RMS agents:

  1. msiexec /x Altiris_MonitorAgentPackage_x64.msi /qn RMS=1 
  2. msiexec /x Altiris_PluggableProtocols_Agent_x64.msi /qn RMS=1

That should uninstall both PPA and the RMS agent.  This can be confirmed by looking in the Symantec Management Agent interface and making sure they are not there.

Then in the following order run these commands on the problematic site server to install both the PPA and the RMS agents:

  1. msiexec /i Altiris_PluggableProtocols_Agent_x64.msi /qn RMS=1
  2. msiexec /i Altiris_MonitorAgentPackage_x64.msi /qn RMS=1

In certain rare instances where the product was upgraded to a later version and then back down, the PPA files may not downgrade properly.  Check the following file and ensure it is the correct version for the current installation: NS Install Drive:\Program Files\Altiris\Pluggable Protocols Agent\Bin\AMTRedirectionService.exe. Right click the executable and click the Details tab.  Look at the version and make sure it matches the install version i.e. 7.x, 8.x etc. This should resolve the issue.