Unable to upgrade a DLP Detection server due to error message that files are locked
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Unable to upgrade a DLP Detection server due to error message that files are locked

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Article ID: 165280

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Updated On:

Products

Data Loss Prevention Endpoint Prevent Data Loss Prevention Network Monitor Data Loss Prevention Network Prevent for Email Data Loss Prevention Network Discover Data Loss Prevention Endpoint Discover

Issue/Introduction

During the DLP detection server upgrade process you encounter an error that states that files are locked and that the detection server upgrade will not complete.

The upgrader precheck has detected one or more locked files in the <drive>:\Symantec\DataLossPrevention\DetectionServer\<DLP version>\Protect\scan directory tree. The upgrade has been canceled. Your system remains on the current version. For further assistance see the Troubleshooting section of the <DLP Version> Upgrade Guide for solutions.

Environment

Windows detection servers

Cause

There is some other process outside of DLP that has a lock on DLP files that prevents the upgrader from updating them.

One way to determine what process is interfering with the upgrader is the following.

1. Launch process monitor.
2. Locally launch the DLP upgrade process on the detection server.
3. After the error message is encountered again, check Process Monitor for any processes that are accessing DLP files.

Resolution

After the process(es) interfering with the DLP upgrade process are identified, make sure they have been stopped before attempting the DLP upgrade again.