Getting Error: "Securlet deactivation in progress. Please wait." while reactivating Securelt in a short period of time
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Getting Error: "Securlet deactivation in progress. Please wait." while reactivating Securelt in a short period of time

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Article ID: 172573

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Updated On:

Products

CASB Security Standard CASB Security Premium CASB Security Advanced CASB Audit CASB Gateway CASB Gateway Advanced

Issue/Introduction

Log into your tenant > go to Store > under Securlets, hover over Office 365 > click Activate. After following the "Office 365 Securlet" tech note, received the error

"Securlet deactivation in progress. Please wait."

This issue is also seen activating the G Suite Securlet.

"Securlet deactivation in progress. Please wait."

Environment

  • CloudSOC 3.x

Cause

The deactivation process takes some time as the process includes a few other sub tasks (like finalizing the tasks in progress, propagate the changes to the whole infrastructure, .. etc) , if the activation happens too soon, it can fail with the mentioned error message.

There are other factors that may extend the deactivation time and make it the process very slow, even after few hours (persistent cache, corrupted files..etc).

 

Resolution

The deactivation process takes some time, it is always a good idea to wait for the system to propagate the changes made (5-15 min) before trying to activate again.

if the issue persists, then there could be other factors involved and the recommendation is to reach out to Cloudsoc support (Processing delays, persistent cache..etc).