Endpoint Protection for macOS reports "Full Disk Access is not enabled"
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Endpoint Protection for macOS reports "Full Disk Access is not enabled"

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Article ID: 176221

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Updated On:

Products

Endpoint Protection

Issue/Introduction

If Symantec Endpoint Protection (SEP) or Symantec Endpoint Security (SES) for Mac is installed on macOS 10.15 and the Full Disk Access System Extension is removed from SEP, the end-user will see a warning with a 'Fix' button. Clicking this 'Fix' button does not auto-correct the issue.

Full Disk Access is not enabled

Environment

macOS 10.15.x

Cause

System administrator removed the Full Disk Access System Extension for Symantec Endpoint Protection.

Resolution

Clicking on the 'Fix' button within the SEP client UI will open the "Security & Privacy" system settings window for Full Disk Access. The system administrator will then need to add the following system extension manually, and select it to enable it:

/Applications/Symantec\ Solutions/Symantec\ Endpoint\ Protection.app/Library/System Extensions/com.symantec.systemextension