ActiveSync Does not Download all Items During Synchronization Session with Symantec Mail Security for Microsoft Exchange (SMSMSE) installed and running
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ActiveSync Does not Download all Items During Synchronization Session with Symantec Mail Security for Microsoft Exchange (SMSMSE) installed and running

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Article ID: 177158

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Microsoft Server ActiveSync only some of the items are downloaded to the mobile device. The number downloaded is different than the number displayed by ActiveSync as the estimated the number of items to download. It takes several synchronization tries to download the complete list of items to your Pocket PC device.

Cause

This problem happens because of Exchange VSAPI timing and the ActiveSync timing requirements.

If a mail item needs to be scanned by Symantec Mail Security for Exchange (SMSMSE) the mail items is place in a low-priority virus scan queue. This item is not downloaded to the mobile device during the ActiveSync session. A mail item may need to be scanned if either 1) it has never been scanned by SMSMSE virus scanning or 2) it has been scanned previously but the virus definitions have changed.

During the next synchronization session the items that were scanned are now downloaded. It may take many replication sessions to download all the items from a folder.

Resolution

This is expected behavior when using virus scanning with Microsoft Exchange. Use one of the following workaround options to mitigate this behavior:

  • Enable Exchange Background scanning and disable re-scan after virus definition updates. Exchange Background scanning uses a low-priority thread to scan items in the background. The Background scan will scan all items in the Information Store that has not been scanned with the latest virus definitions. Once these items have been scanned they do not need to be scanned by SMSMSE when accessed. This should allow for a successful ActiveSync.
  • Schedule virus definitions updates and schedule a scan to run after hours.
    It is recommended to use Certified Liveupdate Definitions instead or Rapid Release Definitions. Rapid Release Definitions are released approximately every hour requiring items to be rescanned with the latest definitions frequently.
  • Disable Auto-Protect and enable SMTP Virus scanning.
    Disabling Auto-Protect will disable on-demand scanning. When on-demand scanning is disabled the problem with Activesync will no longer occur. Emails will be scanned when entering the server through SMTP, but messages entering through MAPI will not be scanned. It is recommended to enable Background scanning or a scheduled scan with this option.

 

Instructions to Enable Exchange background scanning and disable re-scan after virus definition updates:

Note: When choosing a schedule please keep in mind that the background scanning process should scan the message before it is retrieved via ActiveSync. For further details on selecting a schedule for background scanning please refer to the Implementation Guide.

SMSMSE version 5.X

  1. In the SMSMSE console, on the primary navigation bar, click Scans.
  2. In the sidebar, under "Views", click Auto-protect.
  3. Check Enable background scanning.
  4. Under "Advanced Scanning Options" uncheck On virus definition update, force rescan before allowing access to information store.
  5. On the toolbar, click Deploy changes.

 

SMSMSE version 6.X and version 7.X

  1. In the SMSMSE console, on the primary navigation bar, click Scans.
  2. In the sidebar, under "Views", click Auto-protect.
  3. Check Enable background scanning.
  4. Select a schedule for when background scanning is to run.
  5. Under "Advanced Scanning Options" uncheck On virus definition update, force rescan before allowing access to information store.
  6. On the toolbar, click Deploy changes.

 

Instructions to schedule virus definitions updates and schedule a scan to run after hours:

To schedule Liveupdate:

  1. In the console, on the primary navigation bar, click Admin.
  2. In the sidebar, under "Views", click LiveUpdate\Rapid Release Schedule.
  3. Under "Schedule" select Run at a specific time.
  4. Choose a time after hours (use 24-hour clock).
  5. On the toolbar, click Deploy changes.

 

To create a Scheduled Scan:

  1. In the console, on the primary navigation bar, click Scans.
  2. In the sidebar, under "Views", click Scheduled Scans.
  3. In the sidebar, under "Tasks", click New Scan...
  4. In the "Scan name" box, type the name for the scan. Mail Security lets you enter a maximum of 128 SBCS (single-byte character set) characters (64 double-byte character set characters) in the Scan name box.
  5. Under "Scan Options", check Stop after scanning after X minutes to limit the amount of time for the scan, and then type the maximum scanning time in minutes. The default value is 120 minutes. If Mail Security reaches this limit, it stops scanning. The next scheduled scan starts where the previous scan stopped.
  6. Click Next.
  7. Choose which Mailboxes and Public Folders to scan.
  8. Click Next.
  9. Uncheck Enable Content Filtering.
  10. Click Next.
  11. Choose a time for the scan to start. This should be ~10 minutes after Liveupdate is scheduled. Use the 24-hour clock.
  12. Check the days you would like the scheduled scan to run.
  13. Click Finish.
  14. Enable the scheduled scan you just created.
  15. On the toolbar, click Deploy Changes.

 

Instructions to Disable Auto-Protect and enable SMTP Virus scanning:

  1. In the SMSMSE console, on the primary navigation bar, click Scans.
  2. In the sidebar, under "Views", click Auto-protect.
  3. Under "Advanced Scanning Options" Check the box next to Virus scan messages during SMTP transport (recommended for perimeter or gateway servers) mailbox store or a public folder to be mounted.
    Note: With SMSMSE Version 7.0 and later this option is no longer available, SMTP virus scanning is performed automatically.
  4. Uncheck the box next to Enable Auto-Protect.
  5. On the toolbar, click Deploy Changes.

 

For more information about this problem, read the following Microsoft Knowledge Base document: Server ActiveSync does not download all items during a synchronization session