Error: "Not all selected messages could be released..." when releasing messages from Incident or Suspect Virus quarantine
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Error: "Not all selected messages could be released..." when releasing messages from Incident or Suspect Virus quarantine

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Article ID: 177223

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You cannot release mail from either the Suspect Virus Quarantine or Content Incident Quarantine in Symantec Messaging Gateway (SMG).

Symptoms

  • Cannot manually release any messages from the Suspect Virus Quarantine or Content Incident Quarantine.
  • Messages do not automatically release from the Suspect Virus Quarantine or Content Incident Quarantine as scheduled.
  • Messages can be released from the Spam Quarantine.

Not all selected messages could be released. See the Control Center logs for details.

Environment

Conditions

  • SMG Scanner and Control Center are not installed on the same computer.
  • A firewall or network segment may separate the Control Center Ethernet Interface 1 and Scanner roles

Cause

Potential causes

  • The firewall is blocking communication from the SMG Control Center to the Scanner on port 41015.
  • The SMG Scanner is on the same subnet as the IP bound to Ethernet Interface 2 of the Control Center host

Resolution

Firewall Issues

Ensure that communication between the SMG Control Center IP address is allowed to the Scanner IP addresses on TCP port 41015.

When the SMG Control Center is located inside the firewall, and the Scanner is located outside the firewall, TCP port 41015 must be open between the Control Center and the Scanner for Suspect Virus and Content Filtering Quarantine release to operate correctly.

Scanner is on same subnet as Control Center Interface 2

In the SMG 10.8.x releases, the Scanner only trusts the IP address bound to Interface 1 of the Control Center for Content Quarantine releases. If the Scanner IP is on the same subnet as the IP bound to Interface 2 in the Control Center (Administration > Configuration > host > Ethernet) the Control Center will attempt to use Interface 2 to release the message and the scanner will reject the release attempt as untrusted.

The most straightforward way to address this issue is to switch the IP configuration for the Control Center such that the subnet shared by the Scanner and Control Center is bound to Interface 1 rather than Interface 2.

This trust issue will be addressed with a future SMG release so that both Control Center interfaces are trusted for Quarantine release.

 

Note: Messaging Gateway handles messages in the Spam Quarantine differently from messages in the Suspect Virus Quarantine. Messages in the Spam Quarantine are released and delivered directly from the Control Center to the configured internal mail server.