Symantec Management Agent service will not start. Error in logs, "Failed to initialize agent storage: Object already exists"
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Symantec Management Agent service will not start. Error in logs, "Failed to initialize agent storage: Object already exists"

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Article ID: 158898

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Updated On:

Products

IT Management Suite

Issue/Introduction

The Symantec Management Agent service will not start. The error message written to the log file is "Failed to initialize agent storage: Object already exists"

Failed to initialize agent storage: Object already exists

Cause

Security permissions do not allow SYSTEM account to read and write files in folder where the MS Crypto API stores RSA keys.

Resolution

1. Ensure the SYSTEM account has READ/WRITE access to the following folders under C:\ProgramData\Microsoft\Crypto\RSA:

MachineKeys and S-1-5-18

NOTE: Older operating systems will be at this location: C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA

2. You may be required to rename the S-1-5-18 folder in order to get the agent to start.

3. Start Symantec Management Agent service.

4. If you renamed the S-1-5-18 folder, check and see that it has been recreated by the OS