Error: "554 5.7.1 Rejected message by MTA, EHLO domain does not exist in DNS"
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Error: "554 5.7.1 Rejected message by MTA, EHLO domain does not exist in DNS"

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Article ID: 171602

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Updated On:

Products

Messaging Gateway

Issue/Introduction

While using Symantec messaging gateway, The emails are not been delivered due to the unavailability of a Reverse DNS( RDNS) record for an IP address. 

We receive the following error

554 5.7.1 Rejected message by MTA, EHLO domain does not exist in DNS

Environment

Messaging Gateway: All versions

Cause

The sender's DNS records do not have a valid 'A', 'AAAA', or 'MX' entry for the domain presented in the HELO/EHLO commands.

and

You have the rejection of " Messages that fail HELO/EHLO reverse DNS"  checks enabled.

Resolution

The best solution is to have the owner of the IP addresses' DNS records add a PTR record to resolve that IP to a fully qualified domain name (FQDN).

You can also disable the check in SMG:

  1. Log into the Control Center as admin.
  2. Click Protocols.
  3. Click Settings.
  4. Uncheck Reject connections where the domain provided at HELO and EHLO has neither an 'A', nor an 'AAAA', nor an 'MX' record in DNS.
  5. Click Save.