Agent on Site Server fails to register
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Agent on Site Server fails to register

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Article ID: 173980

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Updated On:

Products

Task Server

Issue/Introduction

On Windows 2016 server Task service is installed but the Symantec Management agent (SMA) fails to register to itself

  1. Operation 'Direct: Head' failed.
    Protocol: HTTP
    Host: test.org:80
    Path: /Altiris/ClientTaskServer/Register.aspx
    Connection Id: 371.1320
    Communication profile Id: {C8683B78-2F41-4C7A-BD4B-205F6084CD78}
    Error type: HTTP error
    Error code: HTTP status 401: The request requires user authentication (0x8FA10191)
    Error note: Empty response content received

  2. Could not register using "https://******/Altiris/ClientTaskServer/Register.aspx"

  3. Failed to call web interface by url [https://******/Altiris/ClientTaskServer/Register.aspx?lastResort=true&resourceGuid=da6c4ead-bd50-4c67-bd9f-1acb50183b4b&crc=0008000100001863], error [0x8007274D, No connection could be made because the target machine actively refused it.].

Environment

ITMS 7.6, 8.0

Cause

In IIS, Anonymous and Digest Authentication is disabled for ClientTaskServer site.

Resolution

  1. Open IIS Manager (Start > Control Panel > Admin Tools > Internet Information Services (IIS) Manager)
  2. Drill down to (<server> > Web Sites > Default Web Site > Altiris)
  3. Select "ClientTaskServer" web site and double click on "Authentication" from the menu on right side.
  4. Enable "Anonymous" and "Digest Authentication".
  5. Run iisreset from command prompt.