Inv_AeX_AC_TCPIP gets NULL values in some Computer Resources
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Inv_AeX_AC_TCPIP gets NULL values in some Computer Resources

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Article ID: 176890

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Updated On:

Products

IT Management Suite

Issue/Introduction

The issue was noticed in Resource Manager where some computers have NULL values for the Inv_AeX_AC_TCPIP.
Seems that if Basic Inventory is sent from one of the affected machines, the information is populated correctly.
After checking Inv_AeX_AC_TCPIP table, it was noticed that NULL entries existed for some resources under the Subnet or the IP Address columns.

Running Altiris KB 28720 fixes the issue temporarily but in some point those resources get NULL values again.

Environment

ITMS 7.x, 8.x

Cause

The issue can be due to two major reasons:

1. Having an old version of AeXBasicInventory.dll (meaning, the client machine has an older version of the Symantec Management Agent than the one that the SMP server is running (like the client machine has a 8.1 version agent when the SMP server is running 8.5 version)).

2. Using Browse List Resource Discovery.  The issue is that the Basic Inventory (or Full Inventory) is able to access a lot more information than the Browse List Discovery, and is therefore more correct.  When the Browse List Discovery runs, it will fill the data with what it finds, and when it finds empty data it will fill with a NULL value. This has always been the case and it is not considered a bug. 

 

Resolution

1. Make sure that you are using an updated version of the AeXBasicInventory DLL.

2. Identify when was the last time Inv_AeX_AC_TCPIP table was updated. You can run the following queries to match time stamps:

--Query 1:

SELECT * FROM ResourceUpdateSummary
WHERE inventoryclassguid = '37974FB9-E60E-4027-B72D-19E3F088A6A5' --
Inv_AeX_AC_TCPIP dataclass
AND resourceguid = 'GUID from an affected machine'

--Query 2:

SELECT * FROM Inv_AeX_AC_TCPIP
WHERE _resourceguid = 'GUID from an affected machine'

3. Normally, there is not much information to identify when the NULL values were added. In order to have more details of when those fields are been modified with NULL entries, enable the Resource History for Inv_AeX_AC_TCPIP.
   a) Go to SMP Console >Settings > Notification Server > Resource and Data Class Settings>Resource History
   b) Under Notification Server, in the main frame, select AeX AC TCPIP with this, you should be able to start keeping the history of this table and be able to see when good data is been added and when NULL are inserted. After you are done troubleshooting, disable the history table so you don’t accumulate unnecessary data.
Run this query a day after you enable this resource history for AeX AC TCPIP to check when this table has been modified:

SELECT * FROM InvHist_AeX_AC_TCPIP
WHERE _resourceguid = 'GUID from an affected machine'

4. Check if you are running a Resource Discovery with the Browse List option checked. If that is the case, disable Browse List and leave Membership option checked. Browse List Discovery is very limited and it will add the NULL values.

5. If Resource Discovery is not the problem, try to identify a pattern of when the NULLs are been added. In this case compare when those values are been added between different machines. You can use this query to identify which ones has NULLs under the Inv_AeX_AC_TCPIP table:

SELECT vc.Name, ip.*

FROM Inv_AeX_AC_TCPIP ip

JOIN vComputer vc on vc.Guid = ip._ResourceGuid
WHERE ip.Subnet is NULL


Then choose some of those machines from the results obtained from the query above and   grab the _resourceGuid values for those and replace it on this query:


SELECT * FROM InvHist_AeX_AC_TCPIP
WHERE _resourceguid in (
'GUID from an affected machine',

'GUID from an affected machine'
,
'GUID from an affected machine'
,
'GUID from an affected machine'
)

This should show when NULLs were added to those machines and verify if there is a time frame in common. If that is the case, check your Schedules and see if there is any that run around that time frame.

 

6. If you can't find any specific reason why you still have no data for the TCPIP information sent by the Basic Inventory, run the following query so you can clear out its reference and let the new one coming and update the record:

DELETE FROM ResourceUpdateSummary
WHERE inventoryclassguid = '37974FB9-E60E-4027-B72D-19E3F088A6A5' -- Inv_AeX_AC_TCPIP dataclass
AND resourceguid = 'GUID from an affected machine'