[12064] The engine was unable to be kicked
Error code: 12064
Error text: The engine was unable to be kicked
Affected module: conduit
Product version: Symantec Brightmail Gateway 9.5 and later versions
Symptoms:
This warning is displayed in the conduit_log.
Cause:
After it finishes downloading new rules to the Symantec Messaging Gateway, conduit notifies the Brightmail Engine to load the new rules. In case the engine does not respond to the request, this warning is displayed.
Following are the common reasons for this warning:
The bmserver instance is manually stopped.
The bmserver instance is in the process of restarting, often triggered by changing settings through the Brightmail Control Center.
The bmserver instance is in a broken or unresponsive state due to a crash or memory related issue.
Resolution:
Solution 1 Start stopped services
Determine if the MTA service is running.
Log into the admin CLI and enter the following command:
service mta status
If the bmserver and all the configured MTA are reported as stopped, enter the following command:
service mta start
When the prompt returns, enter the command:
service mta status
At this point, the bmserver process and all the configured MTA instances should be running.
If the bmserver process is reported as stopped while all relevant MTA are reported as running, log into the Control Center, click . Select the checkbox beside Brightmail Engine and click the button. The Status of Brightmail Engine should update to Running and the warning should no longer appear.
Solution 2: Determine if there is an underlying problem
Log into the admin CLI and enter the following command:
list --cores
If there are core files listed in the /data/scanner/jobs/bmserver/
directory, these files are indicated by a date-time format listing such as /data/scanner/jobs/bmserver/2011.07.27-10.20.04
. The format being yyyy.mm.dd-hh.mm.ss. If the timestamp listed for a core file is the same or very close to the timestamp on the warning, it indicates that the bmserver process was recovering from a crash at the time the call to reload rules was issued. Under normal circumstances, the Brightmail Engine is designed to automatically recover from such a crash. The process is restarted automatically and the warning should stop.
You can use the admin CLI diagnostics command to investigate the root cause of the underlying crash. Review any errors occurring in bmserver_log as these may indicate the root cause of the issue that causes the Brightmail Engine crash or being unable to initialize correctly.
Log sample:
The following is an example of the error message as it appears in the conduit_log.
<date>T<time>(WARNING:9086.3061745344): [12064] The engine
was unable to be kicked.
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