Problem
Machines are not installing Patch Management software updates. Logs show the following messages:
Process: AeXNSAgent.exe (1468)
Thread ID: 680
Module: PatchMgmtAgents.dll
Source: SoftwareUpdateAgent
Description: stateChangeEvent() It is time to apply updates
Process: AeXNSAgent.exe (1468)
Thread ID: 680
Module: PatchMgmtAgents.dll
Source: SoftwareUpdateAgent
Description: Ignoring update schedule - updates cannot be applied whilst in this state
NOTE: This text line is not Red (error text) or Blue (warning text), for it is an 'Information' line of text, and therefor will not show as a different color and will not stand out.
Environment
Patch Management Solution for Windows 6.x and 7.x.
Cause
There are multiple reasons that this message can occur.
- The Software Update Agent is not ready. Inventory is running.
- It is already in the middle of a Software Update Cycle.
- Previous updates required a reboot and that has not yet happened or a reboot is in progress.
- Packages are not yet downloaded.
The remote tool in KB 45023 can be helpful when troubleshooting this.
Resolution
As there can be multiple causes there are also potentially multiple resolutions.
- The main cause of this is that the computer is pending a reboot. Reboot the computer.
Note: Restarting the Altiris Services is not enough, the machine must be rebooted.
- Wait for the running Software Update Cycle to finish.
- Verify that packages are downloading and address that if the packages have not yet downloaded.
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