An error message "special value [Blocked File]" Or "Access denied" on UNIX\Linux servers in CCS
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An error message "special value [Blocked File]" Or "Access denied" on UNIX\Linux servers in CCS

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Article ID: 151851

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Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Server Control Compliance Suite Standards Module

Issue/Introduction

Control Compliance Suite (CCS)

An error message "special value [Blocked File]" appears
Or you see an "Access denied" message

Can occur in both agent-based and agentless CCS 12.6.X data collection jobs.

 

Environment

CCS 12.6.X agentless scans and agent-based scans.

Cause

By default, CCS will block and not bring back information on the /etc/passwd and the /etc/shadow files on UNIX\Linux servers.

Resolution

For Agentless data collection:

  1. On every CCS Manager in your environment, manually edit the file "C:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\DPS\control\Unix\ConfigFiles\SecuredFiles.dat" 
    1. Place a hash mark "#" at the beginning of each line as follows:
      1. #/etc/passwd
      2. #/etc/shadow
    2. Restart the 'Symantec CCS Manager' services for the new configuration to take effect.

 

For Agent-based data collection:

  1. On each agent, manually edit the file "/esm/bin/dcmodules/<platform>/UNIX/SecuredFilesList.dat" file and place a hash mark "#" at the beginning of each line as follows:
    1. #/etc/passwd
    2. #/etc/shadow
  2. Restart the CCS agent daemons for the change in the configuration to take effect. (i.e. /esm/esmrc restart)