Modifying the Data Center Security (DCS) or Critical System Protection (SCSP) Agent Communication Port from the default port
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Modifying the Data Center Security (DCS) or Critical System Protection (SCSP) Agent Communication Port from the default port

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Article ID: 151914

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Updated On:

Products

Critical System Protection Data Center Security Server Advanced

Issue/Introduction

I have a port conflict with another application that uses tcp port 2222. How can I change the port the DCS or CSP Agent uses?



 

Environment

CSP: All Versions
DCS: All Versions

Cause


Agent doesn't connect with the manager, or conflicts with another application due to a port conflict with another application which is using port 2222

Resolution

Data Center Security (DCS) Agent


During Agent installation, set the Notification port to something other than port 2222

Configuration Changes (done in the Java Console)

To change the default communication port (2222) for DCS Agent in the Common Parameters:
1. Log into the management console
2. Click on the "Configs" tab and then "Prevention"
3. Right Click "Default Common Parameters" and choose copy to make a copy of the Defaults
4. Right Click on the "Copy of Default Common Parameters" and choose rename it to "Notification Port 2333 Common Parameters" (note: please change the text 2333 to whatever port you intend to use
5. Double click the "Notification Port 2333 Common Parameters" to open it in edit mode
4. Click the "Communication" tab
5. Change the port entry to any numeral from between 1024 to 65535 and click "ok" (In the example below, I picked 2333)


Once this has been completed, please make sure you apply the new common parameters to the Security Group where you will be using the DCS Agents



Critical Systems Protection (CSP) Agent
To change the default communication port on SCSP Agent:
1. Log into the management console
2. Now, click on the "Prevention View" tab at the top of the screen
3. Click on the "Configs" tab on the left below "Policies"
4. Right Click "Default Common Parameters" and choose "Properties"
5. Click the "Communication" tab
6. Change the port entry to any numeral from between 1024 to 65535 and click "ok"
7. Repeat steps 3-6 for the "Detection View" tab

Once this has been completed, please make sure you apply the new common parameters to the agents.

1. Navigate to the 'Prevention View' Tab
2. Click on Assets from the left hand side of the display
3. Under the 'Common Configs' List, click on the 'Common Configuration
4. Select the agents you wish to modify. If you wish to select all of them click on one agent, then 'Ctrl+A'
5. Right click and select 'Apply Config'
6. A dialog box should will appear. Navigate to the newly updated 'Default Common Parameters' it will be suffixed with the version. ie. r1 and select
7. Click Finish
8. This will apply the new configuration to the agent
9. Repeat Steps 2-8 on the 'Detection View Tab'

**Note: No manual restart of services are required to have configuration applied. You can also set or customize the notification port from 2222 during agent installation; however, the settings in 'Default common parameters' take precedence in case of a conflict