Altiris Agent will not install (or Reinstall) via Push Install with error: Installed agent is newer. Install aborted.
search cancel

Altiris Agent will not install (or Reinstall) via Push Install with error: Installed agent is newer. Install aborted.

book

Article ID: 152018

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

When attempting to push the NS Agent (Symantec Management Agent also known as Altiris Agent) to a group of machines, it fails. The following message is seen in the AexNSC.log file:

02-05 15:23:22: ==========================
02-05 15:23:22: AeXInstallPreCheck started
02-05 15:23:22: Current dir: C:\WINDOWS\TEMP\apt0
02-05 15:23:22: AeXInstallPreCheck Finished
02-05 15:23:22: ===========================
02-05 15:23:22:
02-05 15:23:22: Passing control to AeXNSAgent
02-05 15:23:22: Commandline: AeXNSAgent.exe -s -a ns="NSSERVER" nsweb="http://NSSERVER/Altiris/" NOSTARTMENU ADDREMOVE /s
02-05 15:23:22: ===============================
02-05 15:23:22: Core Agent Installation started
02-05 15:23:22: Installed agent in newer.  Install aborted.
02-05 15:23:22: StartAgent, starting core agent.
02-05 15:23:22: Core Agent Installation Ended 
02-05 15:23:22: ===============================

Cause

In the Services screen on the target computer, there is an entry for "Altiris Agent" that is set to Disabled. That is the cause of this issue.

Resolution

To resolve this issue, change the status of the Service by:

1) Open services.msc on the target machine
2) Scroll down to the "Symantec Management Agent" Service
3) Mark it as "Automatic" and Start the service
4) Re-try the Push from the NS Console.

The NS agent should be installed on the target machine.