Enabling Premium AntiSpam on Symantec Mail Security for Microsoft Exchange 6 generates error "The named piped could not be opened"
search cancel

Enabling Premium AntiSpam on Symantec Mail Security for Microsoft Exchange 6 generates error "The named piped could not be opened"

book

Article ID: 152084

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction



Symptoms
Error: "The named piped could not be opened" is generated when installing the Premium AntiSpam license, or when you attempt to enable Premium AntiSpam

 

Cause

We have seen two causes for this issue:

1. The logged in user account used to open the Symantec Mail Security for Microsoft Exchange (SMSMSE) console does not have appropriate rights on the Exchange server to open named pipes.

2. The local system account does not have appropriate permissions on the Exchange server to open named pipes.

Resolution

Create a new user account that is only a member of Domain Admins and SMSMSE Admins to eliminate possible user permissions problems:

  1. Open Active Directory Users and Computers (Start -> Administrative Tools -> Active Directory Users and Computers)
  2. Select your domain, right click and choose New -> User
  3. Name the user something descriptive such as "smsadmin" and click Next
  4. Choose a strong password, and click Next
  5. Uncheck "Create an Exchange mailbox" and click Next
  6. Verify the details on the final page and click Finish.
  7. Expand the Users object.
  8. Select the user account you just created, right click and select Properties
  9. Select the Member Of tab
  10. Click Add... and type in 'Domain Admins' in the box then click Ok
  11. Highlight 'Domain Admins' in the list, and click Set Primary Group.
  12. Highlight 'Domain Users' and click Remove. This will eliminate the possiblity that the domain users group is restricting user rights in some way.
  13. Click Add... and type in 'SMSMSE Admins' in the box then click Ok
  14. Click Apply and then Ok.
  15. Log off the server, and then log back on using the newly created user account.
  16. Attempt to enable Premium AntiSpam in the SMSMSE console, if it works, you have identified the source of the problem as user permissions. If you still get the error, continue with the next section.


Change the permissions context that the SMSMSE service and SMSMSE utility services run under to eliminate possible system account permissions problems:

  1. Open the Services console (Start -> Run, services.msc)
  2. Locate the 'Symantec Mail Security for Microsoft Exchange' service, right click and select Properties
  3. Select the 'Log On' tab
  4. Under the 'Log on as:' section select This account and enter the credentials of the user you created in the previous exercise, click Apply then click Ok.
  5. Repeat Steps 2-4 for the Symantec Mail Security for Microsoft Exchange Utility service.


The Premium AntiSpam license should now register successfully, and you should now be able to enable Premium AntiSpam.