Unable to register the client. ClientTaskServerMaxComputerLimitExceededException
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Unable to register the client. ClientTaskServerMaxComputerLimitExceededException

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Article ID: 152238

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

After a client attempts to register to a server the following error is received:

 

<event date='Apr 07 09:17:54' severity='2' hostName='CLIENTEXAMPLE' source='Client Task Agent' module='client task agent.dll' process='aexnsagent.exe' pid='9708' thread='9256' tickCount='1320745296' >
<![CDATA[CTaskServerNetCommsConnection::CheckResponseXml(): The task server returned an error: <![CDATA[System.Exception: An exception occurred while executing the request ---> System.Exception: System.Exception: Unable to register the client 45afb459-c2ea-4a1c-acf3-0985a5730b5f ---> Altiris.ClientTask.Server.Exceptions.ClientTaskServerMaxComputerLimitExceededException: Exception of type 'Altiris.ClientTask.Server.Exceptions.ClientTaskServerMaxComputerLimitExceededException' was thrown.

   at Altiris.ClientTask.Server.RemoteClientTaskManager.GetClientStatusAndLock(AltirisResourceGuid resourceGuid, Boolean ignoreMaxComputerLimit, ClientStatus& client, Boolean& created)
   at Altiris.ClientTask.Server.RemoteClientTaskManager.RegisterAndCreateClientRecord(AltirisResourceGuid resourceGuid, String configurationXml, Boolean bLastResort)
   at Altiris.ClientTask.Server.ClientTaskServer.RegisterClient(AltirisResourceGuid resourceGuid, Boolean bLastResort, String configurationXml) AtrsLog:Debug
   --- End of inner exception stack trace ---
   at Altiris.ClientTask.Server.ClientTaskServer.RegisterClient(AltirisResourceGuid resourceGuid, Boolean bLastResort, String configurationXml)
   at Altiris.ClientTask.Server.ClientTaskServer.ProcessRemoteRegisterClient(Hashtable input, Hashtable& output)
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingServer.ProcessRequestObject(Object work)
   --- End of inner exception stack trace ---
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingClient.SendRequestI(String service, Hashtable input)
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingClient.SendRequest(String service, Hashtable input)
   at Altiris.ClientTask.Server.HttpHandlers.WebClientApiManager.ProcessRegister(XmlTextWriter wr, NameValueCollection queryValues, Stream requestStream, Int32 contentLength)
   at Altiris.ClientTask.Server.HttpHandlers.Register.WriteResponse(XmlTextWriter wr)
   at Altiris.TaskManagement.Common.XmlHttp.BaseXmlXmlHttpCallback.WriteResponseRaw(XmlTextWriter xwr)
   at Altiris.TaskManagement.Common.XmlHttp.BaseXmlHttpCallback.ProcessRequest(HttpContext context)]]>]]></event>

Environment

ITMS/TS 7.x - 8.x

Cause

The site server/task server that is being connected to has hit the maximum amount of clients allowed.

Resolution

There are a few ways to address this issue:

  1. Assign the client's subnet to more than one site server, this will help distribute the load on the site servers.  When the client attempts to connect to one it should fail and then try to connect to the other.
  2. Increase the number of allowed connections for that server in the Settings > All Settings > Notification Server > Site Server Settings > Task Service > Settings > Task Service Settings
  3. Allow the server to exceed the maximum amount of connections if a computer cannot connect to any other server.