Unable to install Task Service
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Unable to install Task Service

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Article ID: 152265

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Updated On:

Products

IT Management Suite

Issue/Introduction

While adding a new Site Server, we are unable to add task service to the server.

In the Symantec Management Console, in the Settings menu, click Notification Server > Site Server Settings.

The check box is grayed out but Package service gets installed.

Environment

ITMS 8.x

Cause

There are multiple causes for this issue:

1. The prerequisites for Task server are not installed on the client.

2. The filter "Potential Task Servers" is not updating correctly

3. The computer is included in the Cloud-enabled Management Settings policy Applied to target

4. There is some corruption in the itemreference table (most uncommon issue)

Resolution

Solution 1:

Verify you have the proper prerequisites installed on the client machine. This usually includes the proper version of Microsoft .NET, IIS and the latest service pack for the installed OS. For more details on the prerequisites see the installation guide.

Solution 2:

Sometimes there are problems with the "Potential Task Servers" filter. Using the search option in the console find this filter and look at the membership. Try manually updating the membership. The target client needs to be in this membership for the check box to be enabled. When in a pinch, take the resolved SQL and run it in management studio. Try eliminating different requirements in there to see what could be preventing the client machine from being added to the filter.

Solution 3:

Navigate to in the Symantec Management Console to Settings >All Settings > Notification Server > Cloud-enabled Management > Policy > Cloud-enabled Management Settings. Edit the target to exclude the specific site server or all site servers. 

Solution 4:

This is the most uncommon problem. Only continue if the machine is in the filter as mentioned above but the check box is still not enabled. This can happen when the item reference is corrupted, you will need to manually restore the Potential Task Servers. First check the itemreference table for the Potential Task Servers entry:

Run the following SQL:

select i.name, i2.name, ir.* from ItemReference ir
join Item i
on ir.ParentItemGuid = i.Guid
join Item i2
on ir.ChildItemGuid = i2.Guid
where i2.Name = 'Task Service'

This should return two entries. If you do not see an entry for potential Task Servers then you will need to manually add it using the following SQL:

insert into ItemReference
values ('82D42246-52BC-4D94-BF9E-8935921AEE58','37B0AC4C-BDC1-4FB8-BA4B-EAA1BFF30ECB','potentialcollection',0,GETDATE(),GETDATE())

Once you add this back and the client is in the filter then the check box should be enabled.
Related KB Title : Unable to check the "Task Service" Check-box on a Site Server (Remote Task Server) TECH122114