Unable to update the scheduling data associated with the item. System.UnauthorizedAccessException: Access is denied.
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Unable to update the scheduling data associated with the item. System.UnauthorizedAccessException: Access is denied.

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Article ID: 152271

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Updated On:

Products

IT Management Suite

Issue/Introduction

All "NS.*" Symantec Management Platform scheduled tasks are missing.

Process: AeXConfig (7084)
Thread ID: 1
Module: AeXConfig.exe
Source: Altiris.NS.ItemManagement.ItemHelper
Description: An unexpected exception has occured (Exception: Altiris.NS.Exceptions.AeXItemImportException: Item Import exception : 16290a7d-3cee-451e-b4d8-96c5784f12ec = Altiris.NS.StandardItems.Purge.HiddenPurgingMaintenanceItem(62937de7-5931-4d40-a1be-beeb2b88809b) ---> Altiris.NS.Exceptions.AeXException: Unable to update the scheduling information associated with the item ---> Altiris.NS.Exceptions.AeXException: Unable to update the scheduling data associated with the item ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
   at Altiris.Interop.ITaskScheduler.NewWorkItem(String taskName, Guid& rclsid, Guid& riid, Object& unk)
   at Altiris.NS.Scheduling.ScheduleManagerInterop.SetTask(String taskName, String taskData)
   at Altiris.NS.ItemManagement.ItemScheduleMonitor.CreateOrUpdate(IItem item, String oldItemName, Boolean forceOldRemove)
   at Altiris.NS.ItemManagement.ItemScheduleMonitor.Notify(ItemNotificationType type, IItem item, String oldItemName)
   --- End of inner exception stack trace ---
   at Altiris.NS.ItemManagement.ItemScheduleMonitor.Notify(ItemNotificationType type, IItem item, String oldItemName)
   at Altiris.NS.ItemManagement.Item.NotifyItemScheduler(ItemNotificationType notificationType, String oldItemName)
   --- End of inner exception stack trace ---
   at Altiris.NS.ItemManagement.Item.NotifyItemScheduler(ItemNotificationType notificationType, String oldItemName)
   at Altiris.NS.ItemManagement.Item.OnSave(Boolean bExistingItem)
   at Altiris.NS.ItemManagement.Item.Save()
   at Altiris.NS.ItemManagement.Item.Import(XmlNode itemNode)
   at Altiris.NS.ItemManagement.Item.ImportItem(XmlNode itemNode)
   --- End of inner exception stack trace ---
   at Altiris.NS.ItemManagement.Item.ImportItem(XmlNode itemNode)
   at Altiris.NS.ItemManagement.ItemHelper.ImportItemNodesEx(XmlNodeList childItemNodes))

Cause

Task Scheduling is disabled via the GPO.

 

This was done to prevent the spread of a virus:

http://www.symantec.com/connect/blogs/downadup-locking-itself-out

Resolution

The Symantec Management Platform uses the Task Scheduler to run scheduled tasks.

The Windows Task Scheduler needs to be re-enabled on the Notification Server.

Or, set the permissions on C:\Windows\Tasks to read, read and execute, write for SYSTEM and Administrators.

Once the Task Scheduler has been re-enabled, log on the the Notification Server with the Console Session (ID 0).

Start the "?:\Program Files\Altiris\Notification Server\bin\AeXConfig.exe /Configureall" command, to rebuild the missing scheduled tasks. 

Reboot the Notification Server


Applies To

Symantec Management Platform 7.0 SP4 HF1

Symantec Management Platform 7.1 SP2 MP1

Symantec Management Platform 7.5