"Unable to save registration data to your disk" When Attempting to Manually Register a Premium AntiSpam License for Symantec Mail Security for Microsoft Exchange
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"Unable to save registration data to your disk" When Attempting to Manually Register a Premium AntiSpam License for Symantec Mail Security for Microsoft Exchange

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Article ID: 152606

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

When attempting to manually register the Premium AntiSpam License for Symantec Mail Security for Microsoft Exchange, the following error message appears: 

Unable to save registration data to your disk. Please check available disk space or permissions, and try again.

Symptoms

  • A procmon log run during the registration shows paths with C:\path-to\base-dir

The following is an example:

Register.EXE       12204    CreateFile           C:\path-to\base-dir\etc\
Register.EXE       12204    CreateFile           C:\path-to\base-dir\etc\cert.pem.temp
Register.EXE       12204    RegCloseKey          HKLM\System\CurrentControlSet\Services\WinSock2\Parameters\Protocol_Catalog9
Register.EXE       12204    RegCloseKey          HKLM\System\CurrentControlSet\Services\WinSock2\Parameters\NameSpace_Catalog5
Register.EXE       12204    CreateFile           C:\path-to\base-dir\etc\
  • There is a significant amount of free disk space on the drive on which Symantec Mail Security for Microsoft Exchange (SMSMSE) is installed.
  • The bmiconfig.xml file contains paths with C:\path-to\base-dir, like the following examples:
     <logdir>/path-to/base-dir/logs</logdir>
     <spooldir>/path-to/base-dir/spool</spooldir>
     <statsdir>/path-to/base-dir/stats</statsdir>
     <configdir>/path-to/base-dir/SpamPrevention</configdir>
    .
 

Cause

The installation path was not configured in the bmiconfig.xml file.

Resolution

Symantec is aware of this issue.  This article is updated as more information is available.  Subscribe to the article to receive the updates.

1. Open the file bmiconfig.xml in an editor.

Default Location: 32-bit system: C:\Program Files\Symantec\SMSMSE\Server\<version>\SpamPrevention\bmiconfig.xml

Default Location: 64-bit system: C:\Program Files (x86)\Symantec\SMSMSE\Server\<version>\SpamPrevention\bmiconfig.xml

2. Locate XML nodes with /path-to-base-dir in the values.

The following is an example: 

<?xml version="1.0"?>
<!-- Default configuration file for BEIK -->
<installation xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" os="$INSTALLOS$" arch="$INSTALLARCH$" version="4.0.0.1">
 <totalProfiling>false</totalProfiling>
 <productName>SMSMSE</productName><productVersion>6.5.1</productVersion><loadpoint>/path-to/base-dir</loadpoint>
 <logdir>/path-to/base-dir/logs</logdir>
 <spooldir>/path-to/base-dir/spool</spooldir>
 <statsdir>/path-to/base-dir/stats</statsdir>
 <configdir>/path-to/base-dir/SpamPrevention</configdir>

 

Workaround

Trigger SMSMSE to fill in the proper values by completing the following procedure:

1. Open the registry editor (Start -> Run, Regedit).

2. Find the following registry folder :

32-bit systems: HKEY_LOCAL_MACHINE\Software\Symantec\SMSMSE\<version>\Server\Components\SMTP\BMIConfigInit

64-bit systems: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Symantec\SMSMSE\<version>\Server\Components\SMTP\BMIConfigInit

3. In the right pane, locate the value BMIConfigInit, right click it and choose Delete.

4. Restart the Symantec Mail Security for Microsoft Exchange service.

The bmiconfig.xml file should now contain the correct values, and allow registration of your Premium AntiSpam license.

 

 

Additional Information

Looking for the procedure to manually register the Premium Anti-spam license?

How to manually register the license for Premium AntiSpam with Symantec Mail Security for Microsoft Exchange (SMSMSE)