Outbound re-routing does not work as expected when "Outbound Non-Local Mail Delivery" is set to "Use MX Lookup for non-local mail".
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Outbound re-routing does not work as expected when "Outbound Non-Local Mail Delivery" is set to "Use MX Lookup for non-local mail".

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Article ID: 152820

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When email to a specific domain or route is in the Delivery queue and an attempt is made to re-route all messages to that route, to another MTA, from the Messaging Gateway (SMG) Control Center, this error may be displayed: "Error re-routing messages from the message queue. Please check the Control Center log for details", when the "Use MX Lookup for non-local mail" setting is configured under the "Outbound Non-Local Mail Delivery".

"Error re-routing messages from the message queue. Please check the Control Center log for details."

Cause

SMG will not re-route messages when set to use MX lookup to determine the route.

Resolution

The recommended resolution to re-route the messages is:

  1. Update the MX records associated with the domain to contain an accessible list of mail servers
  2. Go to Administration > Configuration > scanner > DNS/Time
  3. Click Flush to flush the DNS cache.
  4. Flush the delivery queue Status > Message Queues.
  5. Click Display Filtered 
  6. Click Flush All

The alternative is:

  1. Under Administration > Configuration > scanner > SMTP > Outbound
  2. Change the "Outbound Non-Local Mail Delivery" from "Use MX Lookup for non-local mail" to "Relay non-local mail to" and configure an IP that is not a mail server. (NOTE: This will prevent any email in the queue from being delivered to an invalid host and being rejected)
  3. Re-route your messages to another MTA host.