Symantec Mail Security for Microsoft Exchange (SMSMSE) Install Rolls Back with No Errors on a 64 bit System When 32-bit Registry Missing IIS Entries
search cancel

Symantec Mail Security for Microsoft Exchange (SMSMSE) Install Rolls Back with No Errors on a 64 bit System When 32-bit Registry Missing IIS Entries

book

Article ID: 153822

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

SMSMSE install rolls back with no errors on a 64 bit system.

Conditions

  • SMSMSE installation log shows the following as the last entry:

MetabaseCreateSmseSite: Success creating SMSMSE site

See the following article on obtaining SMSMSE installation log:  How to Obtain Detailed Logging While Installing Symantec Mail Security for Microsoft Exchange (SMSMSE).

  •  Process Monitor log during installation shows the you'll see repeated entries similar to the following at the time of the install failure: 


Process            Action               Path                                                                                                                                         Result
MsiExec.exe     RegOpenKey     HKCU\Software\Classes\Wow6432Node\CLSID\{61738644-F196-11D0-9953-00C04FD919C1}     NAME NOT FOUND
MsiExec.exe     RegOpenKey     HKU\S-1-5-20_CLASSES\Wow6432Node\CLSID\{61738644-F196-11D0-9953-00C04FD919C1}     NAME NOT FOUND

 

Cause

 The IIS WAM Admin service is not registered in the 32 bit registry.

Resolution

1.  Register the IIS WAM Admin service in the 32 bit registry using the following steps:

a. Open Windows Explorer and navigate to C:\WINDOWS\SysWOW64.
b. Locate and double click the file cmd.exe.
c. Enter the following command:

cd C:\WINDOWS\System32\inetsrv


d. Enter the following command:

regsvr32 wamreg.dll

Verify the following is displayed:

DllRegisterServer in wamreg.dll succeeded

 

2. In order for the next install to proceed successfully, you must also remove some information left behind from the previous failed install.

a. Remove the SMSMSE website:

i. Open the IIS Administrator (Start -> Run, inetmgr).
ii. In the left pane, expand <server name>.
iii. In the left pane, expand Web Sites.
iv. Right click the Symantec Mail Security for Microsoft Exchange website and click Delete.

b. Remove the SMSMSE services:

i. Open a command prompt (Start -> Run, cmd).
ii. Type the command 'sc delete SMSMSE' and press Enter.
iii. Type the command 'sc delete SAVFMSESpamStatsManager' and press Enter.

 

Re-run the install by double clicking setup.exe. SMSMSE should now install successfully.


Applies To

  •  Operating System is 64 bit.