Messaging Gateway Alert: A directory data access error has occurred
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Messaging Gateway Alert: A directory data access error has occurred

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Article ID: 153967

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Messaging Gateway (SMG) is sending alert messages indicatiing that " A directory data access error has occurred"

The Messaging Gateway's Directory Data Service (DDS) logs may report 1 or more of the following Warnings/Errors:

  • [DDSSocketFactory] WARN - [1266451810496] [MCK] Unable to connect to /LDAPSERVER:PORT 
    java.net.SocketTimeoutException: connect timed out
  • com.symantec.sms.dds.api.exception.DataAccessConnectRefusedException: Failure connecting to data source, network connection refused: LDAPSERVER
  • LDAPSERVER:PORT; nested exception is javax.naming.CommunicationException: LDAPSERVER:PORT [Root exception is java.net.ConnectException: Connection refused]

Cause

This alert is reported when a scanner or the Control Center cannot connect to one or more configured directory data sources.

Resolution

Ensure that data sources configured in Administration > Directory Integrarion are reachable from both the Control Center and Scanner hosts

Ways of checking this can include:

- Performing telnet from the Messaging Gateway host's shell console to the LDAP server and port.

- Running one of the test options belonging to the LDAP server in the Directory Data Source settings page.

If one or more of the above tests fails due to a connectivity failure, check that your LDAP server is still functional and there are no network related problems causing the connectivity failure. (For example: Firewall blocking access, routing problems).