Network Discovery Ping sweep will create a resource for every available IP address (in specifed IP range) even if no device has been assigned and\or exists at that IP address.
search cancel

Network Discovery Ping sweep will create a resource for every available IP address (in specifed IP range) even if no device has been assigned and\or exists at that IP address.

book

Article ID: 154477

calendar_today

Updated On:

Products

Altiris Network Discovery

Issue/Introduction

A Network Discovery Ping sweep will create a resource for every available IP address (in specified IP range) even if no device has been assigned and\or exists at that IP address. This results in thousands of resources erroneously created.

Cause

Each Network Discovery task run is associated with a unique Connection Profile. If the associated connection profile has the VMware plug-in option enabled, it will cause a resource to be created for every available IP address (in specified IP range) even if no device has been assigned and\or exists at that IP address. When subsequently accessing the Network Discovery Home Page and viewing "Discovered Device Classification", you will see a large number of devices classified as "Unknown".

Resolution

Rerun the Network Discovery Task using a connection profile that does not have the VMware plug-in option enabled. This will return an accurate number of identifiable resources for the subnet the ND task was run.

Even after the successful Network Discovery task run, you must remove the erroneously created resources. These are all classified as “Network Resources” and can be deleted from the “Organizational Views and Groups”.  To delete them, go to Manage > Default > All Resources > Asset > Network Resource. After this, access Settings > Notification Server > Resource Membership Update and click on “Run” button under the “Complete Update” section.  The erroneous devices should then be removed from the Device Classification report.