SMTP Code: "421 4.4.0 Unable to connect to DNS - try again later" when sending mail to Messaging Gateway
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SMTP Code: "421 4.4.0 Unable to connect to DNS - try again later" when sending mail to Messaging Gateway

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Article ID: 154540

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When sending an inbound message to a Messaging Gateway, the peer gets an error response of "421 4.4.0 Unable to connect to DNS - try again later"

Similar error messages to those below are found in the maillog:

2011 Jun 29 10:34:12 UTC (warning) ecelerity: [23186] sieve: RDNS: RDNS lookup for connecting IP 192.0.2.11 returned SERVFAIL
2011 Jun 29 10:34:12 UTC (info) ecelerity: [23186] ML-REJECT: Rejection on: 192.0.2.9:25,200, sent to host: 192.0.2.11:49653, Audit ID 01010109-b7c6dae000005a92-01-4e0a8f2485e6, 421 4.4.0 Unable to connect to DNS - try again later
2011 Jun 29 10:34:12 UTC (notice) ecelerity: [23186] ESMTP-02739
2011 Jun 29 10:34:12 UTC (info) ecelerity: [23186] ML-HOST_DISCONNECTED: 192.0.2.11:49653 disconnected. (ID 90656f58)

Cause

This issue can occur when you enable any of the DNS Validation features under Potocol > Settings, and there are problems with the configured DNS server(s).

Resolution

Ensure that the configured DNS server is working, and is not overloaded. Navigate to Administration > Configuration > host > DNS/Time.