"Unable to resolve the specified server name or IP" when adding server by IP Address to SMSMSE console
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"Unable to resolve the specified server name or IP" when adding server by IP Address to SMSMSE console

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Article ID: 154746

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

After adding a server by IP address into the Symantec Mail Security for Exchange (SMSMSE) Administration console the following error message is displayed:

Unable to resolve the specified server name or IP.
Please verify that the specified server name or IP is valid.
Internal Error: No such host is known

The IP address is not added to the server list.

Conditions

  • Use the following steps to validate this behavior.

1. Open the SMSMSE administration console.
2. Click the Assets button at the top of the console.
3. Click Tasks|Add Server(s) to bring up the Add Servers(s) dialog box.
4. Enter the IP address in the Server Name or IP textbox.
5. Click  the right facing arrow button.
6. The following error message is displayed:

Unable to resolve the specified server name or IP.
Please verify that the specified server name or IP is valid.
Internal Error: No such host is known

 

  • The computer is unable to look up the hostname associated with the IP address.

Use the nslookup tool to validate this.

1. Open a command prompt and type the following and click Enter:

nslookup

This displays the DNS server used:

Default Server:  internal
Address:  192.x.x.3

 

2. Type the IP address of the server and click Enter.

If the following error message is shown then this condition is met:

*** 192.x.x.3 can't find 192.x.x.181: Non-existent domain

This indicates that the hostname of the IP address cannot be resolved by the DNS server.

NOTE:  When the hostname can be resolved the following message is displayed:

Server:  localhost
Address:  127.0.0.1

Name:    internal
Address:  192.x.x.200

 

 

 

 

 

 

 

Cause

The administration console attempts to look up the hostname of the IP address.  This typically occurs when the remote server is in a different domain than the computer where the administration console is running.

Resolution

Symantec is aware of this issue.  This article is updated as more information is available.  Subscribe to this article to receive updates.

Workaround

Put an entry into the Windows hosts file with an entry for the IP address.  Perform these steps on the computer where the SMSMSE Administration console is reporting the error:

1. Open the following file in Notepad: c:\windows\system32\drivers\etc\hosts
2. Put an entry with a hostname into the file.

The following is an example of assigning hostname 'exchange' to IP address 10.x.x.203:

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost
10.x.x.203 Exchange
 

3. Save the file and exit Notepad.