Outbound email through the Symantec Messaging Gateway (SMG) appliance fails with the message "All recipients are invalid".
search cancel

Outbound email through the Symantec Messaging Gateway (SMG) appliance fails with the message "All recipients are invalid".

book

Article ID: 155059

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

Outbound email through the Symantec Messaging Gateway is rejected with the error, "All recipients are invalid, Rejected message for nonlocal recipient".

The Message Audit Logs contain the following error: "All recipients are invalid, Rejected message for nonlocal recipient"

Cause

If the Messaging Gateway scanner is configured with one IP for Inbound and a different IP for Outbound, verify that the internal mail servers are sending outbound mail to the Outbound interface of the scanner.

If the Messaging Gateway scanner is configured with one IP for Inbound and Outbound, ensure that the internal mail servers are listed as permitted senders.

Resolution

Verify the following:

  • The internal mail server is configured to send to the appropriate outbound interface of Messaging Gateway set in
    • Administration > Configuration > hostname > SMTP > Outbound > Outbound mail IP address
  • The Messaging Gateway scanner is configured to allow the internal mail server to relay mail outbound.
    • Administration > Configuration > hostname > SMTP > Outbound > Outbound Mail Acceptance