When managing a remote server with the Symantec Mail Security for Exchange (SMSMSE) administration console, a dialog box with a large red X is displayed.
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When managing a remote server with the Symantec Mail Security for Exchange (SMSMSE) administration console, a dialog box with a large red X is displayed.

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Article ID: 155340

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

The SMSMSE administration console is attempting to connect to a remote server.  A dialog box requesting credentials is displayed.  After the credentials are entered a dialog box with the title Error is displayed with a large red X image and nothing else.  The dialog box looks like this:

Conditions

  • The version of the SMSMSE administration console is older than the version of SMSMSE installed on the remote server.

The versions of SMSMSE installed are obtained from the SMSMSE administration console (both locally and remotely).  Open the SMSMSE administration console and select the Help|About menu item.

 

  • A network trace shows the error message "Request processing cannot continue. Product is incompatible"

The following steps demonstrate how to use Wireshark to verify this.

1. Start wireshark capture on the computer running the SMSMSE administration console.
2. Open the SMSMSE administration console and reproduce the issue.
3. In the Filter textbox enter the following:

frame contains "Request processing cannot continue. Product is incompatible"

4. Right click on the packet found (if any) and select Follow TCP stream.
5. In the resulting Follow TCP Stream window scroll down to the bottom and find the following response from the remote server:

HTTP/1.1 200 OK
Date: Fri, 04 Nov 2011 17:21:52 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
X-AspNet-Version: 2.0.50727
Cache-Control: private, max-age=0
Content-Type: text/xml; charset=utf-8
Content-Length: 1204

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><PullResponse xmlns="http://symantec.com/cmaf/DExL"><PullResult>&lt;DexlResponse&gt;&lt;Prologue&gt;&lt;Setting&gt;&lt;Type&gt;ProductProperties&lt;/Type&gt;&lt;SubType /&gt;&lt;SettingsXml&gt;&lt;ProductProperties&gt;&lt;ServerName&gt;patti-p0933kl3r&lt;/ServerName&gt;&lt;ProductId&gt;SMSMSE65&lt;/ProductId&gt;&lt;ProductVersion&gt;6.5.2.96&lt;/ProductVersion&gt;&lt;PlatformId&gt;Exchange2003&lt;/PlatformId&gt;&lt;Date&gt;2011-11-04T10:21:52.4028283&lt;/Date&gt;&lt;IsCompatible&gt;0&lt;/IsCompatible&gt;&lt;/ProductProperties&gt;&lt;/SettingsXml&gt;&lt;DeletedXml /&gt;&lt;/Setting&gt;&lt;FailIfServiceStopped&gt;0&lt;/FailIfServiceStopped&gt;&lt;DeleteAll&gt;0&lt;/DeleteAll&gt;&lt;/Prologue&gt;&lt;Response&gt;&lt;Type&gt;Error&lt;/Type&gt;&lt;Success&gt;0&lt;/Success&gt;&lt;Data&gt;&lt;Error&gt;Request processing cannot continue. Product is incompatible.&lt;/Error&gt;&lt;/Data&gt;&lt;/Response&gt;&lt;/DexlResponse&gt;</PullResult></PullResponse></soap:Body></soap:Envelope>Notice the error message that says "Product is incompatible".

 

Cause

The SMSMSE console is designed to only manage the same release line, older versions of the console cannot manage newer versions of the server application, and newer versions of the console cannot manage older versions of the server software.

Resolution

Use the version of the SMSMSE administration console that matches the version on the remote server to manage the remote server. If an organization is running multiple versions in parallel, Symantec recommends running two consoles, one for the new version and one for the old version. As servers are upgraded, remove them from the old console and add them to the new console as part of the upgrade process.