ASP.NET failure when installing or upgrading Workflow
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ASP.NET failure when installing or upgrading Workflow

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Article ID: 155696

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Updated On:

Products

IT Management Suite

Issue/Introduction

Workflow fails to install due to an ASP.NET failure, as visible in a dialog and the Install.log file.

Failed[ASP.NET may be prohibited in your IIS configuration. Please check IIS web service extensions and ensure that ASP.NET is Allowed.

Environment

Applies To

Workflow 7.1 or 7.5 installation on a Windows 2008 R2 machine.
Workflow 8.5 RU4
Workflow 8.6 RU1

Cause

One possible cause is an extraneous entry in the web extensions. 

Another cause could be that the Workflow AppPools are set to Integrated and they only work with Classic.

This error has also been seen when there is a HTTP Redirect on Default Web Site.  Part of our detection check is connectivity to a temporary virtual directory that is created as part of the ASP.Net detection process.

Resolution

This article is written under the assumption that the server is a dedicated Workflow server; it is possible that this may impact other IIS-based applications.

1. Open the IIS Manager.

2. In the center pane, right-click ISAPI and CGI Restrictions and choose Open Feature.

3. There should be two versions of ASP.NET installed, both "ASP.NET v2.0.50727" & "ASP.NET v4.0.30319". Anything else is unnecessary and should be removed.

     

4. Reboot the machine and attempt to install again.

To check if an HTTP Redirect may be causing the issue open a web browser and attempt to go to http://localhost.  If you aren't taken to an IIS7 welcome screen then a HTTP Redirect is in place.

To disable the redirect:

  1. Open IIS Manager
  2. Click on Default Web Site
  3. In the left hand pane double click on HTTP Redirect.
  4. Uncheck the Redirect requests to this destination and click Apply in the Actions pane on the far right.

You may reenable the redirect once the installation has completed successfully if you wish.

 

Note:
For Workflow 8.5 RU4, check if you see a similar Warning entry under the Application Event logs:

The description for Event ID 1309 from source ASP.NET 2.0.50727.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

3005
An unhandled exception has occurred.
7/31/2020 12:20:16 PM
7/31/2020 7:20:16 PM
9c02e3ffb3e4498484d44675f7329a0c
1
1
0
/LM/W3SVC/1/ROOT/__Symantec_Workflow_Setup-3-132406968165297420
/__Symantec_Workflow_Setup
C:\Users\administrator.example\AppData\Local\Temp\2\__Symantec_Workflow_Setup\testInstallVirtualDir\
<Servername>
9796
w3wp.exe
IIS APPPOOL\Classic .NET AppPool
HttpException
The current identity (IIS APPPOOL\Classic .NET AppPool) does not have write access to 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'.
https://smp-main.example.com:443/__Symantec_Workflow_Setup/default.aspx
/__Symantec_Workflow_Setup/default.aspx
fe80::b0ac:6c00:270c:26f3%13
False
IIS APPPOOL\Classic .NET AppPool
3
IIS APPPOOL\Classic .NET AppPool
False
   at System.Web.HttpRuntime.SetUpCodegenDirectory(CompilationSection compilationSection)
   at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)

If so,

1. Go to IIS Manager>Application Pools
2. Select "Classic .NET AppPool." 
3. Open "Advanced Settings" on the left pane.
4. It most likely is set to ApplicationPoolID as Identity. Change it to "LocalSystem". Save.
5. Verify that the Managed Pipeline Mode is set to "Classic" for the Workflow AppPools as they are not supported as "Integrated".
6. Re-run Workflow installation process.