"Database population FAILED" or "MDAC" error during install or upgrade of Data Center Security Server (DCS, or SCSP) -
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"Database population FAILED" or "MDAC" error during install or upgrade of Data Center Security Server (DCS, or SCSP) -

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Article ID: 156006

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Updated On:

Products

Critical System Protection Data Center Security Server Data Center Security Server Advanced

Issue/Introduction

The upgrade or installation of DCS or SCSP server fails during database operations with the error

"Database population FAILED"

OR "Unable to connect to the specified Database. Please verify the database settings and MDAC installation. Proper installation of MDAC 2.7 SP1 or higher is required."

 

MDAC error:

Cause

There are several possible causes for this error:

1. The target SQL database IP address is inaccurate

2. The SCSPDBA password that was entered during setup was not complex enough

3. The TCP/IP setting is disable in SQL Server Configuration

4. The SQL Browser service is stopped

5. The SQL database is offline

6. The communication between the DCS or CSP Management Server and the SQL Server is blocked

7. Mixed mode for the authentication mode is not selected

8. Incorrect instance name used in the installation wizard

9. Previous installation remnants in the database

10. Database owner or users have been changed

11. Model Database is too large

Resolution

Causes & Solutions

1. The target SQL database IP address is inaccurate

The target IP address must be correct

If an improper address is specified, this error will appear as those dependencies are not local. They must be specific to the SQL Instance (SCSP) if using a separate database host.

2. The SCSPDBA password that was entered during setup was not complex enough.

Specific length must be respected

Specific length must be respected: 8 characters minimum including uppercase, lowercase, a number and a non-alphanumeric character (only _ or # are allowed by SCSP).

3. The TCP/IP setting is disable in SQL Server Configuration.

To enable TCP/IP setting in SQL Server Configuration

  1. In the Microsoft SQL Server Configuration manager and in the left pane expand your server group.
  2. Right-click TCP/IP and then click Enable.
  3. Click OK.
  4. Restart the SQL Server service.

Re-run the Symantec Critical System Protection install.

 

4. The SQL Browser service is stopped.

Start the SQL Browser service from services.msc

 Check the collation was set to Latin 

 

5. The SQL database is offline.

To verify that your database is online

  1. In the Microsoft SQL Management console, in the left pane expand your server group.
  2. Look at the icon for your server and verify that the icon for it has a green circle with a white arrow 
  3. If it does not have the green circle with a white arrow, right click and select Start.

Stopped  to Started .

 

6. The communication between the DCS or CSP Management Server and the SQL Server is blocked.

To verify the communication

In SQL Server 2005, the below command is preferred:

  1. Open a command prompt.
  2. Run the command:
    OSQL –U sa –P <sa password> -S <hostname or IP address of SQL box>\SCSP (or database instance name used during the install)
  3. If successful, 1> will be returned.

In SQL Server 2008, the below command is preferred:

sqlcmd -U sa -P <password> -S tcp:<computer name>\<instance name>

 

7. Mixed mode for the authentication mode is not selected.

To verify the authentication mode

  1. In the Microsoft SQL Server Enterprise Manager console, in the left pane expand your server group.
  2. Right-click the your server and then click Properties.
  3. In the Instance Properties dialog box, on the Security tab, verify that the SQL Server and Windows option button is selected.
  4. Click OK.

Re-run the Symantec Critical System Protection install.

8. Incorrect instance name used.

Make sure to use the correct instance name during the installation

9. Previous installation remnants in the database.

The SQL Instance has Dynamic Ports disabled

If the SQL Instance has Dynamic Ports disabled you must specify the port 1433 in the Hostname field during installation.
Example:  <Hostname Or IP Address>:1433

In later versions of DCS, choose the Database Port option (with 1433 as the value) instead of the Database Instance option.

  1. To confirm if Dynamic Ports is disabled in the SQL Server open Sql Server Configuration Manager.
  2. Expand SQL Server Network Configuration
  3. Select Protocols for <Your SQL Instance>
  4. In the right pane right-click TCP/IP and click Properties.
  5. Go to the IP Addresses tab.

If TCP Dynamic Ports does not have a value and a port is specified in TCP Port, Dynamic Ports is disabled.

Manually delete all the files/folders in C:\Program Files (x86)\Common Files\Symantec Shared\SCSP\MSSQL.1\MSSQL\ directory before doing fresh SCSP server installation.

Logs

- %ProgramFiles%\Symantec\Critical System Protection\Server\SISManagementInstallWrapper.txt

- %ProgramFiles%\Symantec\Critical System Protection\Server\SISManagerSetup.txt

- %ProgramFiles%\Symantec\Critical System Protection\Server\msde-dbStatus.txt

 

10. Database owner has been changed

Database owner should be scspdba. If it is set to anything else, change it back to scspdba

Use SQL Management Studio to change the database owner

 

11. Model Database is too large

Initial database creation begins with copying the Model database. CSP/DCS requires that the Model database be 49MB or less at time of install

Use a different SQL instance with a smaller Model database or Shrink the Model database

Decrease the size of the model database following the steps below: 

1. Open Microsoft SQL Server Management Studio
2. Under Databases> System Databases, right-click on Model and open Properties
3. Under 'Files', change the 'Initial Size (MB)' to 1. Click OK

Attachments

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