Error: Please check that the 'Symantec Protection 5.1 or 6.x for SharePoint Servers' service is started or contact your administrator. Code: 4956
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Error: Please check that the 'Symantec Protection 5.1 or 6.x for SharePoint Servers' service is started or contact your administrator. Code: 4956

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Article ID: 156138

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Updated On:

Products

Protection for SharePoint Servers

Issue/Introduction

When connecting to Symantec Protection for SharePoint Servers 5.1.x  or 6.x (SPSS) Console, an error is displayed and the Graphical Interface does not show up.

The following error may be displayed when attempting to connect to the Symantec Protection for SharePoint Servers (SPSS) Console:

 

 

Additionally, the following line may be observed in the SPSS Engine logs:

2011-08-21 00:00:30,"xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx","Server.domain",1344,"Offline","Error","Checking","Cannot connect to host or IP address."

Cause

Multiple causes can be behind this issue. Please check the below possible solutions.

 

(1) The Scan Engine server(s) may not be configured to listen on the correct IP addresses.

The following picture shows the settings page "Scan Engine GUI > Configuration > Protocol" where Scan Engine is not listening on all addresses.


(2) The credentials used to run the Symantec Protection for Sharepoint service are not correct anymore.

Check in Windows Services that the LogOn credentials are still valid and most importantly that they still have the required permissions: Local Administrator for the machine(s) where the SQL and the Sharepoint servers are installed. 

(3) The Symantec application root certificate (DigiCert) for the Sharepoint's Protection Engine was removed or expired.  This is a certificate used to authenticate most all Symantec product  applications before execution.

Resolution

Please consider following the steps below to solve the problem:

 

(A) Properly configure Symantec Scan Engine bindings.

  1. Connect to the Scan Engine interface
  2. Browse to "Configuration > Protocol"
  3. Ensure ICAP is the selected protocol
  4. Click on "Select All" in order to select all IP addresses
  5. Click on the "Save and Apply" icon (top-left screen)

Repeat the same steps for each Scan Engine server in the Sharepoint Farm.

 

(B) Repair the Symantec Protection for Sharepoint installation. 

  1. Make sure the credentials set in the LogOn tab for the Symantec Protection for Sharepoint Server service are correct and have the following permissions: Local Administrator for the machine(s) where the SQL, the front and back end Sharepoint servers are installed. 
  2. Launch the autorun from the same version and chose to Install only the Symantec Protection for Sharepoint console. up file.
  3. Choose to Repair the existing installation. 
  4. You may be asked to allow the Microsoft Internet Information Services (IIS) and Microsoft Sharepoint Server services to be restarted. 

All settings should be kept available after the repair.

(C) To test or check your root certificate:

     1.  locate DigiCert certificate provided in the local machine's Trusted Root Certificate store.

     2.  Download a copy of the SymDiag tool and see if it runs.   Download SymDiag to detect product issues 

     3.  If the following error message displays when executing SymDiag, refer to the following SymDiag article to update the certificate.

           Failed to launch Symantec Diagnostic Tool 

 

 

 

 

 

 

Additional Information

If the above resolution did not solve your issue, please contact Symantec Support to further troubleshoot this issue.

Inspection of the Domain's GPO certificate update policies could prevent root certificate updates.